4.0 Beta and N1QL Startup Connection Issues


#1

Hello all,
I downloaded the latest 4.0 and thought the cbq_engine would be started and enabled by default. But I could never get a connection via cbq query tool. So, I started the engine manually via
./cbq-engine -datastore http://localhost:8091

Now back in cbq, I get a json response with an error count of 1 and code of 3000. Wondering if there’s a step in the setup wizard that I missed toggling a check mark for the engine to start automatically?

Thank you in advance,
Will


#2

Hi Will,

Others have run into this issue. During setup, you need to enable all 3 services: Data, Index, and Query. Only Data is enabled by default, and we will fix that to make the setup simpler.

For now, please do a clean reinstall and select all 3 services.

Thanks,
Gerald