403 wrong user response from sync gateway after the upgrade


#1

Hi all,

I got an problem after upgrading the version for couchbase server and sync gateway

Couchbase server from 4.6 to 5.5
Sync gateway from 1.4 to 2.0

Error
When I pushing the json file via sync gateway, I got below error from sync gateway

2018-09-17T10:43:18.926+08:00 CRUD+: Did not update document "testing" w/ xattr: 403 wrong user

The same json file was workable in the old version on CBS 4.6 and SG 1.4 version but it doesn’t work in new version on CBS 5.5 and SG 2.0 version

Below is the example of the json file what I would like to push to the CB

{
“type”: “layout”,
“options”: [
{“option 1”:“A”,“code”:“a”}
]
}

I found that it worked fine when I changed the “type” to other name like “type123”.

Anyone know that what config I need to update for CBS 5.5 and SG 2.0 or is it a bug for CB when the json content come with “type” this wording?


#2

I got another finding when I use the same json file and import to CB with “new json ID”, it return success, but when I try to use the same document ID with same “new json ID” , it failed again

{
“type”: “layout”,
“options”: [
{“option 1”:“A”,“code”:“a”}
]
}


#3

@kelvin.wong. When you are saying json file, is it sync gateway json file? If yes, can you provide full copy of json file and provide the more logs of sync-gateway.