A request has been made for a service that is not configured or supported by the cluster. Please check the cluster and enable or add a new node with the requested service: data

.net
query

#1

Hi,
I connect to couchbase db with Couchbase.NetClient on .Net.
Bucket is opening but can’t execute query or upsert document.

I get this error.
A request has been made for a service that is not configured or supported by the cluster. Please check the cluster and enable or add a new node with the requested service: data

Any help?


#2

Hi @denizkocaboga,

It looks as though you may be trying to execute a query without any query nodes in your cluster.

What services (you can see these in the ‘server nodes’ tab) is your cluster running?


#3

Hi @matt.carabine ,

@denizkocaboga is my colleague. We have 2 nodes in our cluster and each node has data,index and query services.


#4

was there ever a solution found for this? having very similar problem


#5

I’m having the same problem. When I have a single node in my cluster I can insert a document without any issue. As soon as I add the second node I can no longer successfully insert a document and get the same error referenced above. Both nodes have all four services available. If I add the second node and leave off the “Data” service I still experience the identical symptoms. Does anyone have a solution?


#6

Hi @inblackwell,

Are you using docker by any chance?


#7

Same problem, using Amazon ECS. We have a 2 node cluster with the following services enabled: Data, Index, Query


#8

Could this be because the server node names are using internal IP addresses and we are trying to access the cluster via it’s external IP?


#9

No, I’m not using docker. My installs are just vanilla Ubuntu 16.04 droplets on Digital Ocean. I was not able to figure out the problem. Originally, I setup my droplets on Digital Ocean without private networking (local IPs). I then added private networking by following DO’s tutorial. When I setup my cluster I used the private IPs to connect everything. Even though everything seemed to be setup properly I experienced the Data service error. I was able to get the cluster working by just deleting the droplets and recreating them with the private networking option selected from the beginning. Even so, I chose to setup the cluster using the public IPs instead of the private IPs. It’s not ideal but at least I can insert docs now.