Adding a server node error


#1

Hi

If i attempt to add a server node (using the IP address of a systemon my wireless network), i get the error message "Attention - Failed to reach erlang port mapper. Timeout connecting to “192.168.137.1” on port “4369”. This could be due to an incorrect host/port combination or a firewall in place between the servers."
wha could be wrong?
Regards


#2

As description says, erlang port cannot be reached.
Any firewall in between?
What is your setup?


#3

It seems you have a problem with the Erlang port mapper daemon (epmd) (which allows node to node communication), because your firewall will block this port by default.

You should open it manually. In your firewall settings click allow program, then add the port; and in the port number field enter the port number 4369/tcp. And just in case check and configure your IP tables by using the netsh advfirewall command.

Hope this helps.


#4

You can find information about network configuration here:
http://www.couchbase.com/docs/couchbase-manual-2.0/couchbase-network-ports.html


#5

I opened this port 4369 on both the VM’s i installed couchbase and still facing the same issue of …
Attention - Failed to reach erlang port mapper. Timeout connecting to “XX.XXX.XXX.XXX” on port “4369”. This could be due to an incorrect host/port combination or a firewall in place between the servers.

is there anything else on firewall setting i need to do?


#6

Can you temporary stop all firewall? just to be sure…


#7

its off on both the VM


#8

i think i fix the issue… it was ip4 ip address which is different than one i was using. i used it for remote connection though.