Adding Windows PHP SDK Library to Eclipse


#1

Hello,

I am using the latest php sdk (2.something) and all is well on the server side (zend server 8 on centos 6). We run our phpunit tests on the server side of things with the cli runner and all works. However I am having the most difficult time getting the windows version of the sdk added as a library in my zend studio (rebranded eclipse) so that I can run unit tests in zend studio for unit test authoring.

I am using Windows 7 as a workstation and only using the local php interpreter in eclipse to run code. The couchbase server is on a remote centos server.

Does anyone have any guidance in getting the windows php sdk working with eclipse as an external library?

Thank you!
Jason


#2

I can say from my experience that ‘(2.something)’ needs to be a little less ambiguous, because the version of the SDK that you’re using (at least especially for Windows) certainly matters. If you’re not using the latest Windows SDK drivers, you’re probably going to have a few issues with connectivity and noticeable lag in your app(s).

My experience doesn’t relate, specifically, to eclipse, but I wonder if your SDK version may have something to do with your difficulties.


#3

2.05 is the version on the development machine.


#4

That’s strange. Per the thread I linked to, previously, updating my drivers to 2.0.4 fixed my issue. I haven’t updated to 2.0.5, yet, though.