App Crash during the pull replication with CB Lite v2.6

While testing the offline-online handling during the pull replication we observed one app crash. Also, the replicator status is showing as busy even though the network is not reachable. Let me know if any details available on this.

#### Network status change: Network not reachable
#### Pull Replicator Status: busy
2019-10-24 13:43:07.443301-0700 MyAppQA[3270:1406879] TIC TCP Conn Failed [73:0x282ffac40]: 1:50 Err(50)
2019-10-24 13:43:07.445338-0700 MyAppQA[3270:1406879] Task <13932EE3-E601-40F8-9CF9-29E08FAF7A01>.<0> HTTP load failed (error code: -1009 [1:50])
2019-10-24 13:43:07.445568-0700 MyAppQA[3270:1407637] NSURLConnection finished with error - code -1009
2019-10-24 13:43:07.456576-0700 MyAppQA[3270:1406870] CouchbaseLite Network WARNING: {C4SocketImpl#12}==> litecore::repl::C4SocketImpl wss://qa.service.cloud.data.com/sync_gateway/asset360/_blipsync @0x10ca7cc20
2019-10-24 13:43:07.456621-0700 MyAppQA[3270:1406870] CouchbaseLite Network WARNING: {C4SocketImpl#12} Unexpected or unclean socket disconnect! (reason=errno, code=57)
2019-10-24 13:43:07.489524-0700 MyAppQA[3270:1406870] CouchbaseLite Network WARNING: {C4SocketImpl#13}==> litecore::repl::C4SocketImpl wss://qa.service.cloud.data.com/sync_gateway/asset360/_blipsync @0x10cb0e0d0
2019-10-24 13:43:07.489690-0700 MyAppQA[3270:1406870] CouchbaseLite Network WARNING: {C4SocketImpl#13} Unexpected or unclean socket disconnect! (reason=errno, code=57)
#### Pull Replicator Status: busy
2019-10-24 13:43:07.512035-0700 MyAppQA[3270:1407746] CouchbaseLite Replicator ERROR: {Repl#14}==> litecore::repl::Replicator /var/mobile/Containers/Data/Application/A84F16AF-7EB7-4468-A83B-3F35C3230927/Library/Application Support/CouchbaseLite/asset360-a6ah-cc-edgis-qa.cblite2/ ->wss://qa.service.cloud.data.com/sync_gateway/asset360/_blipsync @0x12024e388
2019-10-24 13:43:07.512236-0700 MyAppQA[3270:1407746] CouchbaseLite Replicator ERROR: {Repl#14} Got LiteCore error: POSIX error 57 "Socket is not connected"
2019-10-24 13:43:07.533939-0700 MyAppQA[3270:1407636] CouchbaseLite Replicator ERROR: {Repl#15}==> litecore::repl::Replicator /var/mobile/Containers/Data/Application/A84F16AF-7EB7-4468-A83B-3F35C3230927/Library/Application Support/CouchbaseLite/asset360-a6ah-cc-edgis-qa.cblite2/ ->wss://qa.service.cloud.data.com/sync_gateway/asset360/_blipsync @0x10cb26ba8
2019-10-24 13:43:07.534209-0700 MyAppQA[3270:1407636] CouchbaseLite Replicator ERROR: {Repl#15} Got LiteCore error: POSIX error 57 "Socket is not connected"
2019-10-24 13:43:07.535803-0700 MyAppQA[3270:1406592] CouchbaseLite Replicator WARNING: CBLReplicator[*> URL[wss://qa.service.cloud.data.com/sync_gateway/asset360]] has already started (state = 4, status = 1); ignored.
2019-10-24 13:43:07.535842-0700 MyAppQA[3270:1406592] CouchbaseLite Replicator WARNING: CBLReplicator[<* URL[wss://qa.service.cloud.data.com/sync_gateway/asset360]] has already started (state = 4, status = 1); ignored.
CouchbaseLiteSwift was compiled with optimization - stepping may behave oddly; variables may not be available.

I couldn’t see any such issue with v2.5.

Could you please open a support ticket, since you are an enterprise customer?

Sure @jayahari.vavachan.