Auto failover on 1 of 4 nodes in a cluster - weird behaviour

Hi guys!
I’m trying to setup an auto failover on a cluster with 4 nodes (2xData + 2xfull-service).
I have already created a replica for each bucket to restore missing data in case of failure on any other node (1 replica in bucket settings).
Unfortunately when I turn off one of the nodes, the failover does not work. How do I know? Number of documents in each bucket is smaller by 25% (1/4) so the data is missing even with replication enabled and when my application is trying to query the database it takes a few seconds before it actually return anything. Somethimes my application return a Couchbase timeout exception.
I’m using Couchbase Server 4.5.1 CE.
Any ideas why this auto failover does not work in my case?
Best, Maciej

Have you ticked “enable auto-failover” in the Cluster Settings - and what failover timeout is set?

Yes, I set it to 30s. I tried 120s (which is default) as well.

Have you already tested out one auto-failover? Auto-failover will only trigger once, you have to manually acknowledge the failover before it’ll trigger again - see

Maybe… I really don’t know because there is no counter, no information. I can’t see this button “Reset …” on the top right so I guess no. Is it working for you? I made all this steps on a fresh cluster with fresh nodes so everything was set to default except this auto-failover switch and timeout which I changed before. Am I doing something wrong?