AWS CloudFormation


#1

Hi

I’m trying to setup couchbase Enterprise in our AWS account from AWS Marketplace. I’m able to launch the “per hour” cloudFormation stack without any issue. However, I’d like to turn on memory-optimized-index option which can only be done during the “add server” process. I downloaded the cloudFormation template and updated the “server-add” command. However, it does not work. I even tried to launch the stack with the original template. The stack is created. However, the servers do not join any cluster. When I go to the portal (x.x.x.x:8091), it asks me to create a server or join a cluster. Any advise?

Thx
Mike Chu


#2

Hi Mike (@m.chu), Did you use the Cloud Formation template on the marketplace and did not work or did you get it from Github repo https://github.com/couchbase-partners/amazon-cloud-formation-couchbase?

Let me add +shomari.liburd@couchbase.com who’s our lead cloud partner solutions architect to help resolve this issue.

Thanks!

Anil Kumar


#3

Hi Anil

We are able to launch a cluster successfully from Marketplace with the “hourly pricing” option. Everything looks great except the cluster is not using “Memory Optimized Index”. According to documentation, “Memory Optimized Index” cannot be enable after the cluster is setup. It has to be enabled during the “server-add” process. I downloaded the template from marketplace and try to launch it manually. My plan is if it work then I can modify the template to enable “Memory Optimized Index”. However, the cluster is not setup if I launch the template outside marketplace(using my template file on my pc). According to
https://github.com/couchbase-partners/amazon-cloud-formation-couchbase/tree/master/marketplace
, “ These templates are used by the Couchbase AWS Marketplace offer. They are not intended to be used outside the Marketplace. Unless you are working on updates to the Couchbase Marketplace offer, you probably want to be using a different template.” Please let know how I can launch a “hourly pricing” stack with “ Memory Optimized Index” turned on.

Thx

Mike Chu


#4

Hi Mike (@m.chu)

Please start with https://github.com/couchbase-partners/amazon-cloud-formation-couchbase/tree/master/generator This will let you run the CFT in your account and you can get a baseline to start with.

I recommend you try the “simple” option and then progress from there. Be sure to change the “License” field to “HourlyPricing”. You may edit server.sh found in /scripts to add more steps to the server-add stage. Please let me know if you need anything else.

Shomari Liburd