Badmatch, error, vbucket_stream_not_found


#1

User-triggered compaction of view challenge/_design/Bet failed: {badmatch,
{error,
{{case_clause,
{{error,
vbucket_stream_not_found},
{bufsocket,
#Port<12364.17303>,
<<>>}}},
[{couch_dcp_client,
init,1,
[{file,

“/home/couchbase/jenkins/workspace/sherlock-unix/couchdb/src/couch_dcp/src/couch_dcp_client.erl”},
{line,
299}]},
{gen_server,
init_it,
6,
[{file,
“gen_server.erl”},
{line,
304}]},
{proc_lib,
init_p_do_apply,
3,
[{file,
“proc_lib.erl”},
{line,
239}]}]}}}. See logs for detailed reason.


#2

Any ideas on what this might be ?


#3

Hi @GeorgeLeon,
Do you know what action leading to the error?
thanks
-cihan


[Error] PROJ[:9999] ##1 GetFeed(): projector.topicMissing
#4

HI @cihangirb ,

First I must say I find your presentations and the other CB team members very helpful and meaningful thanks for that.

We are not in production yet but plan to be in end on this year so we have the time to test cb4.0 as N1QL looks amazing.

The issues we are facing are strange and our system works on CB 3.0.3 without any issues running on 4.0 beta 1 we experiencing different error mentioned here



the last post also has full logs attached for active for download for 15 days since 20-7-2015

also reproduced here
http://wikisend.com/download/542748/collectinfo-2015-07-20T085706-ns_1@192.168.1.231.zip
http://wikisend.com/download/373942/collectinfo-2015-07-20T085706-ns_1@192.168.1.232.zip

We believe all to be related some how we don’t know exactly the actions that lead to the errors but it must be somehow related to Compacting and Indexing

Trying different node set-ups as the Couchbase Connect videos suggest e.g. separate

each node HP 4 cores CPU 24 RAM 3 SDD-122 GB 1 for CenOS 1 for cb-data and 1 for cb-index

and we have 4
and try different configurations e.g.
A)
1 data , 1 index and 1 query

B)
1 with all three ( data , index and query)
1 with index
1 with data
1 query

C)
1 data
2 index
1 query

and other permutations

All our tests show that after 1 night running the indexing hangs and the system is non responsive

configurations we do
1.
curl -X POST -v -d ‘updateInterval=10000&updateMinChanges=100’
'http://admin:adm1n-cb@192.168.1.233:8091/settings/viewUpdateDaemon
2.
Swappiness is turned off
3.
Disable Transparent Huge Pages (THP)
as per http://blog.couchbase.com/often-overlooked-linux-os-tweaks

auto compact is as is default
and 2 buckets we have we set both to High priority Disk I/O Optimization
and replication is disabled

Cihan any help is welcome at this point . If more logs or info is need please do not hesitate to ask
Also I have no problem to remove the other Topics if it helps clarity to have only one topic.

A work around we find is if we trigger a FailOver then cancel it then rebalance the system finds its way and starts to work again properly .

Regards ,
George Leon

Betiator
Greece


#5

thanks for the details and complements. glad you fund the presentations helpful.
looks like you are on the 4.0 beta (build 2213). there has been a large number of fixes since that build. would you be interested in deploying a more up to date build of 4.0 an trying again?


#6

yes of course it would be my pleasure please give rpm for CentOS 7


#7

great. pls reach out at cihan@couchbase.com thanks
-cihan


#8

@cihangirb
ok you got it