Bandwidth control for sync_gatewat 2.x

Good morning everybody

We are evaluating to use a radio infrastructure instead of a usual wifi/3g network for our application. The requirements to use this technologies is the support to IPv6, which I saw it should work properly, and a bandwidth of 2kb/s (which is pretty low I think).

So, there is any way to control the sync_gateway bandwidth or, do you have any benchmark on the amount of traffic generated by the sync_gateway?
Also if you have any suggestion for the use of IPv6 it appreciated.

Thanks for any feedback
Have a good day

Hi Paolo,

Am I correct in thinking your Sync Gateway deployment will have a hardwired connection to Couchbase Server? So backend bandwidth isn’t too much of a concern? Only Sync Gateway <–> Couchbase Lite?

There’s no built-in mechanisms to restrict replication bandwidth. Sync Gateway will generally use whatever is available.
The amount of traffic sent to Couchbase Lite clients is mostly determined by the documents being sent, along with a few low-bandwidth heartbeat mechanisms to keep the connection open to clients.

It sounds like your deployment could also benefit quite a lot from the delta sync feature we released in 2.5

Yes, sync_gateway and server are in the same host.

Thanks, I think this might help also in our regular configuration. May I ask why by default is disabled? Might get involved in some “consistency issue”?

Thanks a lot.

It requires additional storage in Couchbase Server to store copies of previous document bodies to be able to diff and patch from, which can be undesireable for some customers.

By default, it will keep 24 hours of updates to every document, but can be tuned up or down with rev_max_age_seconds property to suit your particular document lifecycle. There’s some more info in the rev_max_age_seconds link.

There were also a few issues at launch with delta sync in SG 2.5.0, but these were patched in 2.5.1.

In addition to what Ben said, note that the delta sync feature is Enterprise Edition only . And please upgrade to 2.5.1 EE (or better, 2.6.0 EE )to enable this.

1 Like

Thanks I will. Have a nice day.