Bucket cant be accessed when using N1QL

query
n1ql
#21

I was facing a similar issue yesterday/today with cb 4.0. We have a bucket with a password, and connecting to it via the java sdk openBucket(bucket,password) command and then executing queries. We just suddenly started receiving the keyspace not found no bucket named [bucket]. I then tried to run the query through cbq command line and received the same error. After a restart, it started working again. We had not made any changes to any configuration or anything. I will see if the logs were retained after a restart.

#22

If possible, you may want to increase the log level in case it happens again. Logs do stick around after a restart. They should be available unless you have reinstalled.

If you can run a cbcollect_info from the console UI and identify the uploaded files, we should have something to look at.

#23

Same problem, fixed with server restart.
I unfortunately cannot reproduce, and I only have Info level logging from when it was happening.

#24

This problem was hard to reproduce, but we think it was rooted in bug https://issues.couchbase.com/browse/MB-19656. Check the ‘query.log’ for your server to see if you have errors like:

[Error] GetSettingsConfig() failed: Get http://127.0.0.1:8091/_metakv/indexing/settings/config: CBAuth database is stale. Was never updated yet.

or:

_level=WARN _msg=CbAuth not initialized

If so, then the problem was fixed in 4.5.1.

#25

I can confirm that I was using 4.5.0 and that I got the second error that you mentioned:

_level=WARN _msg=CbAuth not initialized

Very good, will have to update.
Thanks!