Bucket user must have Bucket Full Access and Bucket Admin roles to retrieve metadata purge interval

Using the Capella UI, I have created a user called sync-gateway, with read & write access to all buckets and scopes.

When adding a DB via Sync Gateway using a CURL command, I still get 403 error. Any ideas what I should be doing?

p.s. After seeing the youtube videos of Daniel James, I’ve tried to create a user via CURL but the URL does not work as it says:

This is a DNS SRV record, so usage outside of a Couchbase SDK (e.g. curl) requires resolution of the record first

And I don’t know how to resolve the couchbase url to a real url.

Here is the error:

2022-05-12T16:39:04.226-07:00 [WRN] 403 Forbidden attempting to access <ud>/settings/autoCompaction</ud>.  Bucket user must have Bucket Full Access and Bucket Admin roles to retrieve metadata purge interval. -- base.retrievePurgeInterval() at bucket.go:591

Here is the CURL command:

curl --request PUT 'http://localhost:4985/couchmusic/' \
                   -H 'Content-Type: application/json' \
                   -H 'Authorization: Basic blahblahbase64' \
                   --data-raw '{ "bucket": "couchmusic", "num_index_replicas": 0 }'

Here is the screen shot from Capella showing the user permissions:

ScreenShot 2022-05-12 at 16.42.17

Thank you in advance!

@oyalhi - unfortunately at this time we are not able to support Sync Gateway connecting to Couchbase Capella. Trust me though, we are working on it as one of our highest priorities and I expect to be able to share good news with you in the relatively near future.

Well that’s a bummer but glad and excited that it’s in the works.