Cannot install Couchbase SG: error 1721


#1

Hi everyone. My first post is about an issue. I can’t install Couchbase Sync Gateway 1.2.1 on Windows 10. Even my roommate can’t on his laptop.

The error is: Error 1721. There is a problem with Windows installer package ecc…

I’ve to do an exam on Couchbase Lite… this is very important.

Thank you for your help.

UPDATE:

I’ve managed to install the older version 1.2. Is there any important difference? Should i upgrade it?


#2

I’ve posted a workaround for this issue on its ticket


#3

Hi. Thank you for your answer.

I don’t know how, actually the version of SG that is installed in my pc is the 1.2.1-4. Yesterday was the 1.2.

In your workaround i didn’t understand if i have to unistall the current version first.


#4

You don’t have to, you can retrieve the binary sync_gateway.exe file manually using that method and overwrite it. However if you already have 1.2.1-4 then you are up to date.