Cannot start server in Centos 7


#1

I’m installing Couchbase 5.1.1 community on Centos7 (centos-release-7-5.1804.el7.centos.2.x86_64), already have run below commands:

  • setenforce 0

  • systemctl daemon-reexec

And had tried reinstalling Couchbase server after these 2 commands, the result is:

Redirecting to /bin/systemctl status -l couchbase-server.service
● couchbase-server.service - Couchbase Server
Loaded: loaded (/usr/lib/systemd/system/couchbase-server.service; enabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Mon 2018-07-09 17:39:11 HKT; 2min 54s ago
Docs: http://docs.couchbase.com
Process: 18903 ExecStop=/opt/couchbase/bin/couchbase-server -k (code=exited, status=1/FAILURE)
Process: 18793 ExecStart=/opt/couchbase/bin/couchbase-server – -noinput (code=exited, status=1/FAILURE)
Main PID: 18793 (code=exited, status=1/FAILURE)

Jul 09 17:39:07 dev1 systemd[1]: Started Couchbase Server.
Jul 09 17:39:07 dev1 systemd[1]: Starting Couchbase Server…
Jul 09 17:39:08 dev1 couchbase[18793]: {error_logger,{{2018,7,9},{17,39,8}},“global_trace:~n~p”,[{loop_the_locker,{multi,[],[],[],‘nonode@nohost’,false,false}}]}
Jul 09 17:39:09 dev1 couchbase[18793]: {“init terminating in do_boot”,{{badmatch,{error,eacces}},[{init,start_it,1,[]},{init,start_em,1,[]}]}}
Jul 09 17:39:10 dev1 systemd[1]: couchbase-server.service: main process exited, code=exited, status=1/FAILURE
Jul 09 17:39:10 dev1 couchbase[18903]: NOTE: shutdown failed
Jul 09 17:39:10 dev1 couchbase[18903]: {badrpc,nodedown}
Jul 09 17:39:11 dev1 systemd[1]: couchbase-server.service: control process exited, code=exited status=1
Jul 09 17:39:11 dev1 systemd[1]: Unit couchbase-server.service entered failed state.
Jul 09 17:39:11 dev1 systemd[1]: couchbase-server.service failed.


#2

Hi littlewitchanita,
Thanks for using our Couchbase Server.
I tried on CentOS 7.4 and did not get any issue.
https://friendpaste.com/2d7KcbguPBqk6JDpAYFA5A
I will update my server and rerun your steps above


#3

After update my centOS server to 7.5, I could not reproduce the issue following your steps above.

[root@s44015 ~]# cat /etc/redhat-release
CentOS Linux release 7.5.1804 (Core)
[root@s44015 ~]# rpm -i couchbase-server-community-5.1.1-centos7.x86_64.rpm
Minimum RAM required : 4 GB
System RAM configured : 3.93 GB

Minimum number of processors required : 4 cores
Number of processors on the system : 4 cores

You have successfully installed Couchbase Server.
Please browse to http://s44015:8091/ to configure your server.
Please refer to http://couchbase.com for additional resources.

Please note that you have to update your firewall configuration to
allow connections to the following ports:
4369, 8091 to 8094, 9100 to 9105, 9998, 9999, 11207, 11209 to 11211,
11214, 11215, 18091 to 18093, and from 21100 to 21299.

By using this software you agree to the End User License Agreement.
See /opt/couchbase/LICENSE.txt.

[root@s44015 ~]# setenforce 0
[root@s44015 ~]# systemctl daemon-reexec
[root@s44015 ~]# rpm -e couchbase-server-community
warning: /opt/couchbase/var/lib/couchbase/config/config.dat saved as /opt/couchbase/var/lib/couchbase/config/config.dat.rpmsave
warning: /opt/couchbase/etc/couchdb/local.ini saved as /opt/couchbase/etc/couchdb/local.ini.rpmsave
[root@s44015 ~]# rm -rf /opt/couchbase/
[root@s44015 ~]# rpm -i couchbase-server-community-5.1.1-centos7.x86_64.rpm
Minimum RAM required : 4 GB
System RAM configured : 3.93 GB

Minimum number of processors required : 4 cores
Number of processors on the system : 4 cores

You have successfully installed Couchbase Server.
Please browse to http://s44015:8091/ to configure your server.
Please refer to http://couchbase.com for additional resources.

Please note that you have to update your firewall configuration to
allow connections to the following ports:
4369, 8091 to 8094, 9100 to 9105, 9998, 9999, 11207, 11209 to 11211,
11214, 11215, 18091 to 18093, and from 21100 to 21299.

By using this software you agree to the End User License Agreement.
See /opt/couchbase/LICENSE.txt.

[root@s44015 ~]# systemctl status couchbase-server
● couchbase-server.service - Couchbase Server
Loaded: loaded (/usr/lib/systemd/system/couchbase-server.service; enabled; vendor preset: disabled)
Active: active (running) since Mon 2018-07-09 08:35:21 PDT; 15s ago
Docs: http://docs.couchbase.com
Main PID: 24690 (beam.smp)
CGroup: /system.slice/couchbase-server.service
├─24690 /opt/couchbase/lib/erlang/erts-5.10.4.0.0.1/bin/beam.smp -A 16 – -root /opt/couchbase/lib/erlang -progname erl – -home /opt/couchbase – -smp enable -kernel inet_dist_listen_min 21100 inet_dist_listen_max 21299 error_logger…
├─24705 /opt/couchbase/lib/erlang/erts-5.10.4.0.0.1/bin/epmd -daemon
├─24765 /opt/couchbase/lib/erlang/erts-5.10.4.0.0.1/bin/beam.smp -A 16 -sbt u -P 327680 -K true -swt low -MMmcs 30 -e102400 – -root /opt/couchbase/lib/erlang -progname erl – -home /opt/couchbase – -smp enable -setcookie nocookie -…
├─24796 sh -s disksup
├─24798 /opt/couchbase/lib/erlang/lib/os_mon-2.2.14/priv/bin/memsup
├─24799 /opt/couchbase/lib/erlang/lib/os_mon-2.2.14/priv/bin/cpu_sup
├─24801 inet_gethost 4
├─24802 inet_gethost 4
├─24803 /opt/couchbase/lib/erlang/erts-5.10.4.0.0.1/bin/beam.smp -P 327680 -K true – -root /opt/couchbase/lib/erlang -progname erl – -home /opt/couchbase – -pa /opt/couchbase/lib/erlang/lib/appmon-2.1.14.2/ebin /opt/couchbase/lib/…
├─24876 sh -s disksup
├─24877 /opt/couchbase/lib/erlang/lib/os_mon-2.2.14/priv/bin/memsup
├─24879 /opt/couchbase/lib/erlang/lib/os_mon-2.2.14/priv/bin/cpu_sup
├─24885 /opt/couchbase/bin/priv/godu
├─24886 sh -s ns_disksup
├─24891 /opt/couchbase/bin/priv/godu
├─24913 /opt/couchbase/bin/saslauthd-port
├─24918 /opt/couchbase/bin/memcached -C /opt/couchbase/var/lib/couchbase/config/memcached.json
├─24919 portsigar for ns_1@127.0.0.1
├─24932 /opt/couchbase/bin/goport -graceful-shutdown=false -window-size=524288
└─24938 /opt/couchbase/bin/goxdcr -sourceKVAdminPort=8091 -xdcrRestPort=9998 -isEnterprise=false

Jul 09 08:35:21 s44015 systemd[1]: Started Couchbase Server.
Jul 09 08:35:21 s44015 systemd[1]: Starting Couchbase Server…
Jul 09 08:35:22 s44015 couchbase[24690]: {error_logger,{{2018,7,9},{8,35,22}},“global_trace:~n~p”,[{loop_the_locker,{multi,[],[],[],‘nonode@nohost’,false,false}}]}
[root@s44015 ~]#


#4

Hi, thanks for the reply. In my case, I will see “Permission denied” in the installation step already if the 2 commands have not been run.

I have rolled back to Centos 6 for the time being, will take a look again on Centos 7 in the near future.

Thanks.


#5

I have a question.
Since Couchbase Server for Centos 6 and Centos 7 are different in installation, what Couchbase Server version did you install on Centos 7?
You mention that 2 commands have not been run. Which commands are they?
Thanks


#6

I’ve been using Couchbase 5.1.1 community for Red Hat 7 for Centos 7, and Red Hat 6 for Centos 6.

I’ve even tried installing the one for Red Hat 6 on Centos 7, it succeeded, but the CPU kept on quite a high level even with no request. So I don’t think the version for Red Hat 6 is suitable for Centos 7.

The 2 commands are:
setenforce 0
systemctl daemon-reexec