Can't seem to retrieve information from couchbase server via curl -u Administrator:password1



Might be a stupid problem but I am new to this so please forgive me. Exactly as the title says, I was trying to change XDCR settings via:

curl -XPOST -u Administrator:[mypassword]
-d xdcrMaxConcurrentReps=8

And it simply timed out:
shell > curl: (7) Failed connect to; Operation timed out

I tried to just view the settings:
curl -u Administrator:[mypassword]

and the same thing happened. Am I doing something wrong? I was following the instructions on this page:

Thank you!


Can you do other curl admin operation?
Do you have any special characters in your password like “@” or “:” ?


I am not sure regarding other admin operations, could you give me an example to try? Sorry, I’m very new to couchbase.

Regarding my password, there are no special characters in it at all.

Thank you!


Hello Levonio99,

Don’t you think it could be a network issue?
Can you access the administration console from your browser? ( )

Have you tried to run the curl from the local machine?

For me I can only think about a network issue.