CB 4.0 beta spatial view crashes


#1

Hi all,

I’m working with geojson and spatial views. It has always been working but for a few days now, geospatials views are no more working?

Here ie CB output from REST request on the view:

{"error":"function_clause","reason":"[{vtree_io,decode_kvnode_value,\n           [<<0,0,0,0,1,0,32,0,0,0,0,204,173,29,65,0,0,0,0,20,202,29,65,0,0,0,\n              64,27,126,83,65,0,0,0,128,222,126,83,65>>],\n           [{file,\"/home/couchbase/jenkins/workspace/sherlock-unix/geocouch/vtree/src/vtree_io.erl\"},\n            {line,174}]},\n {vtree_io,decode_kvnode_pairs,2,\n           [{file,\"/home/couchbase/jenkins/workspace/sherlock-unix/geocouch/vtree/src/vtree_io.erl\"},\n            {line,230}]},\n {vtree_modify,modify_multiple,5,\n               [{file,\"/home/couchbase/jenkins/workspace/sherlock-unix/geocouch/vtree/src/vtree_modify.erl\"},\n                {line,303}]},\n {vtree_insert,insert,2,\n               [{file,\"/home/couchbase/jenkins/workspace/sherlock-unix/geocouch/vtree/src/vtree_insert.erl\"},\n                {line,62}]},\n {spatial_view,flush_writes,2,\n               [{file,\"/home/couchbase/jenkins/workspace/sherlock-unix/geocouch/gc-couchbase/src/spatial_view.erl\"},\n                {line,472}]},\n {spatial_view,process_log_file,5,\n               [{file,\"/home/couchbase/jenkins/workspace/sherlock-unix/geocouch/gc-couchbase/src/spatial_view.erl\"},\n                {line,410}]},\n {spatial_view,'-update_spatial/3-fun-0-',3,\n               [{file,\"/home/couchbase/jenkins/workspace/sherlock-unix/geocouch/gc-couchbase/src/spatial_view.erl\"},\n                {line,395}]},\n {lists,zipwith,3,[{file,\"lists.erl\"},{line,436}]}]"}

#2

Hi cambierr,

that looks like a pretty bad bug.

Can you describe what you did? Did you upgrade your Couchbase? Or copied some spatial view files around? Or was it working and suddenly not anymore? Perhaps after compaction?

Cheers,
Volker


#3

This issue gets tracked as MB-15975.