CB Lite 1.1.0.1 for Android Newtonsoft.Json dependency


#1

The new NuGet package for Couchbase Lite 1.1.0.1 seems to be forcing Newtonsoft.Json version exactly 6.0.4 for the MonoAndroid framework only. All other frameworks have dependencies on 6.0.8 or greater.

I want to upgrade to 1.1, but this seems to be forcing my Android application to downgrade Newtonsoft.Json to 6.0.4. The problem is that I’m using other NuGet packages that depend on Newtonsoft.Json 6.0.8 or greater.

I’m just curious as to whether there’s actually a hard dependency on 6.0.4 for Android or if it’s just a mistake in the NuGet packaging?


#2

It is not a mistake. The Android version has some issues with 6.0.8 so unfortunately we had to keep it back.


#3

@ryanthompson0123 As a “workaround”, you can try the 1.1.0 nuget directly, which will permit upgrading to 6.0.8, but caveat emptor with respect to Xamarin.Android.

@borrrden can you post the link here for users like @ryanthompson0123?


#4

Sure, you can install it on the package manager command line via Install-Package Couchbase.Lite -Version 1.1.0 or we have a direct download here


#5

@borrrden ha, I meant the link to the JSON.NET/Android issue in 6.0.8.


#6

I don’t think I ever made one, because I couldn’t pin down exactly what was happening at the time. I’ll take another look now that it is becoming a bigger problem.


#7

Well, I looked into it again and I must have done something to make it happy because I am not seeing the problem anymore (it might have been when I stopped using the default settings for serialization). If it holds up then it will be 6.0.8 in the next version.