Cbq-engine error: Invalid datastore uri:

n1ql

#1

We’re struggling a lot with the current documentation.

According to this doc we just be able to just start the cbq-engine with ./cbq-engine. Though, when we do that we get this error:

http://developer.couchbase.com/documentation/server/4.0/n1ql/n1ql-intro/cbq.html

$./cbq-engine
_time=2015-11-05T00:45:55Z _level=ERROR _msg=Invalid datastore uri:

Any idea how we can fix this?


#2

specifying the datastore yields this:

sudo ./cbq-engine -datastore=http://127.0.0.1:8091 _time=2015-11-05T01:29:24Z _level=ERROR _msg= Unable to initialize cbauth. Error Unable to initialize cbauth's revrpc: cbauth environment variable CBAUTH_REVRPC_URL is not set _time=2015-11-05T01:29:24Z _level=WARN _msg=Unable to intialize cbAuth, access to couchbase buckets may be restricted _time=2015-11-05T01:29:24Z _level=ERROR _msg=Cannot connect url http://127.0.0.1:8091 - cause: HTTP error 401 Unauthorized getting "http://127.0.0.1:8091/pools":

I have a feeling that i’m missing some documentation links. Is this the best place to get the documentation?
http://developer.couchbase.com/documentation/server/4.0

I find a lot missing :frowning:


#3

I assume you have Couchbase 4.0 installed and have enabled “Query” service on your node(s). If you are trying to execute a N1QL query using cbq (shell) then use “cbq” instead of “cbq-engine” (since the latter is the query service and NOT the shell).

To use the cbq shell
http://developer.couchbase.com/documentation/server/4.0/n1ql/n1ql-intro/cbq.html

cbq (space) -engine - The “space” is important
For example, as per instruction in above URL:
./cbq -engine=http://123.45.67.89:8093