Cbrestore Error sqlite3 module


#1

I using Ubuntu, Couchbase 4.1.0-5005 Community Edition (build-5005)
Using cbrestore to import a bucket

Error:
Error : could not import required version of sqlite3 module
when i did that
1- cd /opt/couchbase/bin
2- ./cbrestore ~/backup -u ADMIN -p PASS -x rehash=1 http://localhost:8091 -b XXX -B XXX


4.1 Community Edition examples not loading
#2

Hi,

I also just ran into this problem. I’m on community 4.0.0, but just upgraded to ubuntu 16.04. It turns out that there’s a very petty (in my mind) problem of version checking for sqlite. Looks like sqlite version in 16.04 is 3.11 while it’s 3.8.x in 14.04 (at least what I’m running). The code calls for a minimum sqlite version of 3.3. Unfortunately, python is evaluating 3.11 to be less than 3.3 (I assume it’s looking at it alphabetically, though I’m no python expert).

I was able to move past it by manually editing /opt/couchbase/lib/python/pump_mbf.py. Comment out lines: 34,35,36,39,40. Use this for line references, https://github.com/couchbase/couchbase-cli/blob/4.0.0/pump_mbf.py

It’s not ideal to just remove the check, but I don’t have the time or inclination to figure out how to fix the bug in python. Hopefully someone from couchbase will pick up on this as I imagine it’s an easy fix if you know python.

Good luck!
Travis


#3

did the same thing and it worked perfectly

thanks


#4

I’m really using ubuntu 16.04 but didn’t work, When I edited /opt/couchbase/lib/python/pump_mbf.py file it worked thanks.