Change Data RAM Quota Cluster


#1

Hello all,

I scaled up my nodes from 14GIG to 30 GIg each. Now I want to increase Data RAM Quota for my cluster.

I think I am not doing it the right way, see here:

couchbase-cli setting-cluster --cluster-ramsize=10000 --cluster=cbcluster2-01-us-us-east-1.dev.cld.touchtunes.com:8091 --user Administrator --password admin-d

ERROR: unable to set cluster configurations (400) Bad Request
{“errors”:{"_":“Total quota (14000MB) exceeds the maximum allowed quota (13759MB) on node ‘ns_1@cbcluster2-01-us-us-east-1.dev.cld.touchtunes.com’”}}

Anyone can help out?

Thanks,

Steeve


#2

@steevebisson

You can change it in the ADMIN UI in the =>Settings tab.

But looks like cbcluster2-01-us-us-east-1.dev.cld.touchtunes.com is not upgraded to 30GB.

PRO TIP - uses elastic ip ,if you can, couchbase is hostname and ip specific… so if you restart the machine with a new hostname or random ip the couchbase node will not startup. you’ll have to re-install.


#3

@househippo

I cannot change the settings in the UI, The SAVE button is greyed out.


Thanks for the tip for the IP. I am actually using AWS Internal Route53. If the node explodes, I simply spawn an new instance and change the DNS entry.


#4

Ok I was able to change it with proper values using the cli:

couchbase-cli setting-cluster --cluster-ramsize=16000 --cluster=couchbase-01-us-us-east-1.dev.cld.touchtunes.com:8091 --user Administrator --password admin-d

SUCCESS: set cluster settings

My cluster name was incorrect.

Im good now thanks for the help.