Cluster does not use the increased RAM quota


#1

I increased the Data RAM quota in the settings tab. An hour has passed after I made the change. The cluster does not seem to want to use the other RAM although only ~20% of documents are in RAM. Here’s a screenshot of the overview.

What can I do so that the cluster uses the unallocated RAM?

Thanks, Ben


#2

There’s no “speculative paging” of items into free memory currently - until a non-resident item is operated on (read or modified) it won’t be fetched from disk and cached in memory.


#3

Thanks @drigby! Your answer makes perfect sense. Would you also know why the values “low water mark” and “high water mark” did not change yet. Is this also expected behaviour?


#4

High and Low watermark are per-bucket. Have you also increased the individual buckets’ RAM quota after increasing the per-server quota?


Replace a node, and rebalance
#5

That helped! First I edited the Data RAM quota in Setting - Cluster - Cluster RAM Quota. Now I edited the bucket and the low and high water mark values went up immediately. Thanks for helping!