Command line special character password not working


#1

Hi,
I cannot use administrative cli tools as I’ve set Admin password with special chars.
example: hq<33%b#tbHs:d&t]M5w’Aa
now if i call cbbackup -p hq<33%b#tbHs:d&t]M5w’Aa it gets truncated because of “<”
the same happens when I try to reset the password.
is there any workaround apart from copying the directory and resinstalling?
thanks


#2

Hello @mikbin80,

I believe this is a shell issue and not a Couchbase Server one, if the special characters (<,&,’) are escaped using a back slash, it should work:

cbbackupmgr backup -c localhost:9000 -u backup -p hq\<33%b#tbHs:d\&t]M5w\’Aa  -a ~/backup/ -r test

Another option is to inclose the whole password in double quotas, so the shell does not parse the special characters:

./cbbackupmgr backup -c localhost:9000 -u backup -p "hq<33%b#tbHs:d&t]M5w’Aa" -a ~/backup/ -r test

If that is the real password I would also recommend changing it.

Please let me know if that helped.


#3

Hi Pvarley,
I did not mean its a couchbase issue, just asked for workaround.
double quote works fine.
thanks a lot
Michele


#4

@mikbin80 Happy that the workaround solved the issue. :slight_smile: