Community 2.2: ns_server: "Protocol: ~p: register error: ~p~n\",[\"inet_tcp\",{{badmatch,{error,duplicate_name}}


#1

I’ve compiled Couchbase 2.2 official tarball on Gentoo Linux x64 with following prerequisites installed:

  • gcc: 4.8.2
  • openssl: 1.0.1f
  • erlang: 14B04
  • v8: 8.3.25
    (others omitted, but present)

All epm/beam processes were killed (clean reboot, and checked ‘ps aux’), snode parameter was added with a name pointing to 127.0.0.1 in /etc/hosts.

Result:

[ns_server:info,2014-04-08T17:52:13.012,meta@int31:<0.140.0>:supervisor_cushion:die_slowly:80]Service ns_server exited on node meta@int31 in 0.79s

[error_logger:error,2014-04-08T17:52:13.012,meta@int31:error_logger<0.6.0>:ale_error_logger_handler:log_msg:76]** Generic server <0.141.0> terminating
** Last message in was {#Port<0.3278>,{exit_status,1}}
** When Server state == {state,#Port<0.3278>,ns_server,
{[“Kernel pid terminated (application_controller) ({application_start_failure,kernel,{shutdown,{kernel,start,[normal,[]]}}})”,
“Crash dump was written to: erl_crash.dump.1396964951.5080”,
[],
"{“Kernel pid terminated”,application_controller,"{application_start_failure,kernel,{shutdown,{kernel,start,[normal,[]]}}}"}",
"{error_logger,{{2014,4,8},{17,52,12}},std_info,[{application,kernel},{exited,{shutdown,{kernel,start,[normal,[]]}}},{type,permanent}]}",
"{error_logger,{{2014,4,8},{17,52,12}},supervisor_report,[{supervisor,{local,kernel_sup}},{errorContext,start_error},{reason,shutdown},{offender,[{pid,undefined},{name,net_sup},{mfargs,{erl_distribution,start_link,[]}},{restart_type,permanent},{shutdown,infinity},{child_type,supervisor}]}]}",
"{error_logger,{{2014,4,8},{17,52,12}},supervisor_report,[{supervisor,{local,net_sup}},{errorContext,start_error},{reason,{‘EXIT’,nodistribution}},{offender,[{pid,undefined},{name,net_kernel},{mfargs,{net_kernel,start_link,[[meta,shortnames]]}},{restart_type,permanent},{shutdown,2000},{child_type,worker}]}]}",
"{error_logger,{{2014,4,8},{17,52,12}},crash_report,[[{initial_call,{net_kernel,init,[‘Argument__1’]}},{pid,<0.21.0>},{registered_name,[]},{error_info,{exit,{error,badarg},[{gen_server,init_it,6},{proc_lib,init_p_do_apply,3}]}},{ancestors,[net_sup,kernel_sup,<0.10.0>]},{messages,[]},{links,[#Port<0.58>,<0.18.0>]},{dictionary,[{longnames,false}]},{trap_exit,true},{status,running},{heap_size,377},{stack_size,24},{reductions,439}],[]]}",
"{error_logger,{{2014,4,8},{17,52,12}},“Protocol: ~p: register error: ~p~n”,[“inet_tcp”,{{badmatch,{error,duplicate_name}},[{inet_tcp_dist,listen,1},{net_kernel,start_protos,4},{net_kernel,start_protos,3},{net_kernel,init_node,2},{net_kernel,init,1},{gen_server,init_it,6},{proc_lib,init_p_do_apply,3}]}]}",
empty],

IPV6 support was disabled later without effect, a number of attempts on -snode, hostnaming and IP address had no positive effect too.
Any ideas?