Compatibility Sync Gateway with Couchbase Lite

#1

We are currently running SyncGateway 1.5 which is used by mobile clients using Couchbase Lite 1.4. However, since we would like to upgrade to Ubuntu 18.04 we cannot remain on SyncGateway 1.5 anymore.
Is it safe to upgrade Sync Gateway from 1.5 to 2.5 without it breaking all current mobile clients which will remain on Couchbase Lite 1.4? Are there any known caveats?

#2

This table might help you figure it out.
https://docs.couchbase.com/couchbase-lite/current/compatibility.html

Also this one
https://docs.couchbase.com/sync-gateway/2.5/compatibility-matrix.html

#3

It is compatible but I am curious as to what you are not upgrading lite to 2.x? Couchbase Lite 1.4 is EoL so we will not be doing any official releases on 1.x…