Connection reset by peer on sink cbrestore


#1

Hello,
i’m trying to move my cluster to another cluster in a different server at different ip.
In my source server i did (as docs says) (HOST for example 192.1.1.3):

cbbackup http://HOST:8091 ~/backups -u Administrator -p password

and my sink server (HOST for example 192.1.1.2):

cbrestore ~/backups http://HOST:8091 -b omnitrace -u Administrator -p passoword -v

but console shows me (the host in this case was 127.0.0.1, but i tried also with the real ip, and the same error happened):

2018-08-22 13:42:11,630: mt cbrestore...
2018-08-22 13:42:11,630: mt  source : /home/stefano/backups
2018-08-22 13:42:11,630: mt  sink   : http://127.0.0.1:8091
2018-08-22 13:42:11,630: mt  opts   : {'username': '<xxx>', 'verbose': 1, 'extra': {'max_retry': 10.0, 'rehash': 0.0, 'dcp_consumer_queue_length': 1000.0, 'data_only': 0.0, 'uncompress': 0.0, 'nmv_retry': 1.0, 'conflict_resolve': 1.0, 'cbb_max_mb': 100000.0, 'report': 5.0, 'mcd_compatible': 1.0, 'try_xwm': 1.0, 'backoff_cap': 10.0, 'batch_max_bytes': 400000.0, 'report_full': 2000.0, 'flow_control': 1.0, 'batch_max_size': 1000.0, 'seqno': 0.0, 'design_doc_only': 0.0, 'allow_recovery_vb_remap': 0.0, 'recv_min_bytes': 4096.0}, 'collection': None, 'ssl': False, 'threads': 4, 'to_date': None, 'key': None, 'password': '<xxx>', 'id': None, 'bucket_source': 'omnitrace', 'silent': False, 'dry_run': False, 'from_date': None, 'bucket_destination': None, 'add': False, 'vbucket_list': None, 'separator': '::'}
2018-08-22 13:42:11,633: mt Starting new HTTP connection (1): 127.0.0.1
2018-08-22 13:42:11,643: mt bucket: omnitrace
2018-08-22 13:42:11,666: s0 error: async operation: error: conn.send() exception: [Errno 104] Connection reset by peer on sink: http://127.0.0.1:8091(omnitrace@127.0.0.1:8091)
2018-08-22 13:42:11,676: w0   source : /home/stefano/backups(omnitrace@127.0.0.1:8091)
2018-08-22 13:42:11,676: w0   sink   : http://127.0.0.1:8091(omnitrace@127.0.0.1:8091)
2018-08-22 13:42:11,676: w0          :                total |       last |    per sec
error: conn.send() exception: [Errno 104] Connection reset by peer

What am i doing wrong?

Thanks in advance


#2

Hi,
Thanks for using our software.
Could you tell us what Couchbase Server you are running for this issue? And what operating system(centos, ubuntu or windows)?

I did backup from one cluster and restore to another cluster on Couchbase Server 5.5.0 Enterprise Edition. It works as expected in Centos 7.5 64-bit

Blockquote
[root@s44015 ~]# /opt/couchbase/bin/cbbackup http://localhost:8091 -u Administrator -p password /tmp/backup/
[####################] 100.0% (20000/estimated 20000 msgs)
bucket: bucket0, msgs transferred…
: total | last | per sec
byte : 786888 | 786888 | 76213.3
done
[root@s44015 ~]# /opt/couchbase/bin/cbrestore /tmp/backup/ http://172.23.xx.xx:8091 -u Administrator -p password
[####################] 100.0% (20000/estimated 20000 msgs)
bucket: bucket0, msgs transferred…
: total | last | per sec
byte : 786888 | 786888 | 210962.8
done
[root@s44015 ~]# /opt/couchbase/bin/cbrestore /tmp/backup/ http://172.23.xx.xx:8091 -u Administrator -p password --bucket-source=bucket0 --bucket-destination=bucket1
[####################] 100.0% (20000/estimated 20000 msgs)
bucket: bucket0, msgs transferred…
: total | last | per sec
byte : 786888 | 786888 | 195842.9
done
[root@s44015 ~]#

Thanks


#3

Hi,
i’m using couchbase 5.1.1 community edition with Ubuntu 18.04 bionic beaver.


#4

Hi,
For Couchbase Server 5.1.1, we only support Ubuntu 14.04 and Ubuntu 16.04 64-bit. Ubuntu 18.04 will be supported in future release.
Here is the link for the support platform in 5.0.x and 5.1.x
https://developer.couchbase.com/documentation/server/5.0/install/install-platforms.html
Another question about your issue. What Couchbase Server version you download and install on your Ubuntu 18.04?
Thanks


#5

Although we does not support Ubuntu 18.04 on Couchbase Server 5.1.1 Community Edition. I did try out it in AWS.
I install Couchbase Server Ubuntu 16.04 5.1.1 CE on Ubuntu 18.04 in AWS. I could not reproduce your issue.

Blockquote
root@ip-172-31-9-24:/home/ubuntu# cat /opt/couchbase/etc/
couchbase/ couchdb/ default/ error_maps/ logrotate.d/ runtime.ini security/
root@ip-172-31-9-24:/home/ubuntu# cat /opt/couchbase/etc/runtime.ini
; Configuration Settings at install-time and runtime. Couchbase may
; modify this file, for example, at runtime when the server is secured
; and taken out of Admin Party mode.
[product]
title = Couchbase Server
version = 5.1.1-5723
license = community
root@ip-172-31-9-24:/home/ubuntu# python -V
Python 2.7.15rc1
root@ip-172-31-9-24:/home/ubuntu# /opt/couchbase/bin/cbrestore /tmp/backup/ http://172.31.9.24:8091 -u Administrator -p password -v
2018-08-24 17:15:21,873: mt cbrestore…
2018-08-24 17:15:21,873: mt source : /tmp/backup/
2018-08-24 17:15:21,873: mt sink : http://172.31.9.24:8091
2018-08-24 17:15:21,873: mt opts : {‘username’: ‘’, ‘verbose’: 1, ‘extra’: {‘max_retry’: 10.0, ‘rehash’: 0.0, ‘dcp_consumer_queue_length’: 1000.0, ‘data_only’: 0.0, ‘uncompress’: 0.0, ‘nmv_retry’: 1.0, ‘conflict_resolve’: 1.0, ‘cbb_max_mb’: 100000.0, ‘report’: 5.0, ‘mcd_compatible’: 1.0, ‘try_xwm’: 1.0, ‘backoff_cap’: 10.0, ‘batch_max_bytes’: 400000.0, ‘report_full’: 2000.0, ‘flow_control’: 1.0, ‘batch_max_size’: 1000.0, ‘seqno’: 0.0, ‘design_doc_only’: 0.0, ‘allow_recovery_vb_remap’: 0.0, ‘recv_min_bytes’: 4096.0}, ‘collection’: None, ‘ssl’: False, ‘threads’: 4, ‘to_date’: None, ‘key’: None, ‘password’: ‘’, ‘id’: None, ‘bucket_source’: None, ‘silent’: False, ‘dry_run’: False, ‘from_date’: None, ‘bucket_destination’: None, ‘add’: False, ‘vbucket_list’: None, ‘separator’: ‘::’}
2018-08-24 17:15:21,876: mt Starting new HTTP connection (1): 172.31.9.24
2018-08-24 17:15:21,886: mt bucket: bucket0
2018-08-24 17:15:22,171: w0 source : /tmp/backup/(bucket0@127.0.0.1:8091)
2018-08-24 17:15:22,171: w0 sink : http://172.31.9.24:8091(bucket0@127.0.0.1:8091)
2018-08-24 17:15:22,171: w0 : total | last | per sec
2018-08-24 17:15:22,171: w0 batch : 11 | 11 | 39.1
2018-08-24 17:15:22,171: w0 byte : 676888 | 676888 | 2404250.9
2018-08-24 17:15:22,171: w0 msg : 10000 | 10000 | 35519.2
[####################] 100.0% (10000/estimated 10000 msgs)
bucket: bucket0, msgs transferred…
: total | last | per sec
batch : 11 | 11 | 30.3
byte : 676888 | 676888 | 1863089.2
msg : 10000 | 10000 | 27524.3
2018-08-24 17:15:22,252: mt Starting new HTTP connection (1): 172.31.9.24
2018-08-24 17:15:22,254: mt Starting new HTTP connection (1): 127.0.0.1
done
root@ip-172-31-9-24:/home/ubuntu# /opt/couchbase/bin/cbrestore /tmp/backup/ http://172.31.9.24:8091 -u Administrator -p password --bucket-source=bucket0 --bucket-destination=bucket1 -v
2018-08-24 17:15:48,031: mt cbrestore…
2018-08-24 17:15:48,031: mt source : /tmp/backup/
2018-08-24 17:15:48,031: mt sink : http://172.31.9.24:8091
2018-08-24 17:15:48,032: mt opts : {‘username’: ‘’, ‘verbose’: 1, ‘extra’: {‘max_retry’: 10.0, ‘rehash’: 0.0, ‘dcp_consumer_queue_length’: 1000.0, ‘data_only’: 0.0, ‘uncompress’: 0.0, ‘nmv_retry’: 1.0, ‘conflict_resolve’: 1.0, ‘cbb_max_mb’: 100000.0, ‘report’: 5.0, ‘mcd_compatible’: 1.0, ‘try_xwm’: 1.0, ‘backoff_cap’: 10.0, ‘batch_max_bytes’: 400000.0, ‘report_full’: 2000.0, ‘flow_control’: 1.0, ‘batch_max_size’: 1000.0, ‘seqno’: 0.0, ‘design_doc_only’: 0.0, ‘allow_recovery_vb_remap’: 0.0, ‘recv_min_bytes’: 4096.0}, ‘collection’: None, ‘ssl’: False, ‘threads’: 4, ‘to_date’: None, ‘key’: None, ‘password’: ‘’, ‘id’: None, ‘bucket_source’: ‘bucket0’, ‘silent’: False, ‘dry_run’: False, ‘from_date’: None, ‘bucket_destination’: ‘bucket1’, ‘add’: False, ‘vbucket_list’: None, ‘separator’: ‘::’}
2018-08-24 17:15:48,035: mt Starting new HTTP connection (1): 172.31.9.24
2018-08-24 17:15:48,045: mt bucket: bucket0
2018-08-24 17:15:48,362: w0 source : /tmp/backup/(bucket0@127.0.0.1:8091)
2018-08-24 17:15:48,362: w0 sink : http://172.31.9.24:8091(bucket0@127.0.0.1:8091)
2018-08-24 17:15:48,363: w0 : total | last | per sec
2018-08-24 17:15:48,363: w0 batch : 11 | 11 | 35.1
2018-08-24 17:15:48,363: w0 byte : 676888 | 676888 | 2157542.9
2018-08-24 17:15:48,363: w0 msg : 10000 | 10000 | 31874.4
[####################] 100.0% (10000/estimated 10000 msgs)
bucket: bucket0, msgs transferred…
: total | last | per sec
batch : 11 | 11 | 29.9
byte : 676888 | 676888 | 1838973.9
msg : 10000 | 10000 | 27168.1
2018-08-24 17:15:48,416: mt Starting new HTTP connection (1): 172.31.9.24
2018-08-24 17:15:48,418: mt Starting new HTTP connection (1): 127.0.0.1
done
root@ip-172-31-9-24:/home/ubuntu#


#6

I install the 5.1.1 version following this guide. https://linuxconfig.org/how-to-install-couchbase-server-on-ubuntu-18-04-bionic-beaver-linux.
Do you think is because of the installation?