Couch Base Developer build installation error


#1

Hi,
I downloaded couch base 5.5 DB from this link
https://www.couchbase.com/downloads?family=server&product=couchbase-server-developer&edition=enterprise

after successful download I run following command but it show error

$ sudo dpkg -i couchbase-server-enterprise_5.5.0-Mar-ubuntu16.04_amd64.deb 
dpkg: warning: files list file for package 'oracle-java8-installer' missing; assuming package has no files currently installed
dpkg: warning: files list file for package 'oracle-java9-installer' missing; assuming package has no files currently installed
(Reading database ... 227432 files and directories currently installed.)
Preparing to unpack couchbase-server-enterprise_5.5.0-Mar-ubuntu16.04_amd64.deb ...
Warning: Transparent hugepages looks to be active and should not be.
Please look at https://developer.couchbase.com/documentation/server/current/install/thp-disable.html as for how to PERMANENTLY alter this setting.
Warning: Swappiness is not set to 0.
Please look at https://developer.couchbase.com/documentation/server/current/install/install-swap-space.html as for how to PERMANENTLY alter this setting.
Minimum RAM required  : 4 GB
System RAM configured : 7.67 GB

Minimum number of processors required : 4 cores
Number of processors on the system    : 4 cores
Upgrading previous couchbase ... (5.1.0-5552-1)
/var/lib/dpkg/tmp.ci/preinst: 61: /var/lib/dpkg/tmp.ci/preinst: /opt/couchbase/bin/install/systemd-ctl: not found
dpkg: error processing archive couchbase-server-enterprise_5.5.0-Mar-ubuntu16.04_amd64.deb (--install):
 subprocess new pre-installation script returned error exit status 127
Errors were encountered while processing:
 couchbase-server-enterprise_5.5.0-Mar-ubuntu16.04_amd64.deb

#2

@yogesh_0586, are you using 64-bit ubuntu 16.04?


#3

Yes, I have 64-bit Ubuntu 16.04


#4

Couchbase is using systemd, does your system has systemd installed?