Couchbase 3.0.2 Error Log


#1

I have the following error occurring often in the Couchbase error.log Both errors seem separate one related to stats and the other a web request (I assume the API) Both the traces also point to proc_lib.erl line 239

Any ideas what would be the cause. Couchbase was working fine until we migrated to a new server. I suspect something went wrong with the migration.

[ns_server:error,2015-03-20T0:34:26.940,ns_1@couchbase.hosta.net:<0.387.0>:menelaus_web:loop:170]Server error during processing: [“web request failed”,
{path,"/pools/default/buckets/default/ddocs"},
{type,exit},
{what,
{killed,
{gen_server,call,
[‘capi_set_view_manager-default’,
{foreach_doc,
#Fun<capi_ddoc_replication_srv.2.125277061>},
infinity]}}},
{trace,
[{gen_server,call,3,
[{file,“gen_server.erl”},{line,188}]},
{capi_ddoc_replication_srv,
full_live_ddocs,2,
[{file,
“src/capi_ddoc_replication_srv.erl”},
{line,62}]},
{capi_ddoc_replication_srv,
sorted_full_live_ddocs,1,
[{file,
“src/capi_ddoc_replication_srv.erl”},
{line,76}]},
{menelaus_web_buckets,
do_handle_ddocs_list,3,
[{file,“src/menelaus_web_buckets.erl”},
{line,1253}]},
{request_throttler,do_request,3,
[{file,“src/request_throttler.erl”},
{line,59}]},
{menelaus_web,loop,2,
[{file,“src/menelaus_web.erl”},
{line,149}]},
{mochiweb_http,headers,5,
[{file,
"/home/buildbot/buildbot_slave/centos-6-x64-302-builder/build/build/couchdb/src/mochiweb/mochiweb_http.erl"},
{line,94}]},
{proc_lib,init_p_do_apply,3,
[{file,“proc_lib.erl”},{line,239}]}]}]

[stats:error,2015-03-10T16:36:19.980,ns_1@couchbase.hosta.net:<0.22742.0>:stats_collector:handle_info:124]Exception in stats collector: {exit,
{{badmatch,{error,closed}},
{gen_server,call,
[‘ns_memcached-default’,
{stats,<<>>},
180000]}},
[{gen_server,call,3,
[{file,“gen_server.erl”},{line,188}]},
{ns_memcached,do_call,3,
[{file,“src/ns_memcached.erl”},
{line,1399}]},
{stats_collector,grab_all_stats,1,
[{file,“src/stats_collector.erl”},
{line,84}]},
{stats_collector,handle_info,2,
[{file,“src/stats_collector.erl”},
{line,116}]},
{gen_server,handle_msg,5,
[{file,“gen_server.erl”},{line,604}]},
{proc_lib,init_p_do_apply,3,
[{file,“proc_lib.erl”},{line,239}]}]}


#2

Hey. It looks like there’s something going on in the view engine.

To help you more, we’ll need to see the output of the cbcollect_info tool. [1]

Once you’ve got the output from cbcollect_info, please create a Jira issue [2] and attach the various logs generated by cbcollect_info, along with any supporting information that you think could be useful.

  1. http://docs.couchbase.com/admin/admin/CLI/cbcollect_info_tool.html
  2. https://issues.couchbase.com/browse/MB