Couchbase 4.0 community "IP address seems to have changed. Unable to listen on 'ns_1@hostname'."


#1

Hello,

I’m using Couchbase 4.0 community edition on CentOS 7 and I’m frequently getting the following error message:

IP address seems to have changed. Unable to listen on ‘ns_1@servername.example.com’.

The hostname in the error message resolves to the IP address “10.0.0.11” - and this IP address is set as a static IP address on eth1 interface. Threfore I’m 100% sure that the IP address does not change. Also the cluster and all servers do keep working without any interruptions.

Is there anything else which might cause this error message?
Is there anything I can do, so I don’t get this error message again?

Best, Peter


#2

Does anyone have an idea what might be causing this issue?


#3

I occasionally receive the same warning, too. My cluster also does not seem to have any issues. You can tick this checkbox in the settings “Node’s IP address has changed unexpectedly”. I’m also interested in what causes this issue. Is it a bug in Couchbase or do I need to make changes to my cluster.

Thanks, Ben


#4

I am having this problem too and quite frequent.

Setups: 6 node cluster of CE 4.5. Running on windows 2008 on AWS EC2s.

Sometimes this cause auto failover and I will have to rebalance.

Any fix?


#5

It got a little better with 4.5.1 but what really reduced the number of times I do see this message, was manually adding all other nodes hostnames in the /etc/hosts file (does also exist on windows I think it’s located in c:\windows\system32\drivers\etc\hosts )