Couchbase 6.0.4 WEB UI not working after upgrading from 5.5.6

Hello,

We just upgraded Couchbase from 3.x to 6.0.4. I’ll try to give a short story of the steps that were done to see if something I did was not intended or should be avoided since I have all the backup and can restart.

  1. CB 3.1.2 was installed using non-sudo/non-root mode (using rpm2cpio command);
  2. I did a cbbackup of the data on 3.x and also a tar.gz on the config folder;
  3. I installed CB 4.x (using rpm2cpio in a different folder [did all the commands detailed in the installation guide])
  4. Booted CB up, went all good and web UI presents the option to “create or join to a cluster”;
  5. I shutdown the CB 4.x and proceed to swap the config folder of CB 4.x from the CB 3.x
  6. I initiate CB 4.X again and the web UI presents now the form to login, where i am able to login and see the buckets (which are empty), then i use cbrestore of the data, and the data is now visible in the web UI
  7. CB 4.x is working fine as expected so i do a cbbackup of the data, shut down CB and make a tar.gz of the config folder.
  8. Steps 3 to 6 are repeated but for installation of CB 5.x, and then swap/cbrestore is from what was done in step 7.
  9. Everything is working as expectedin CB 5.x, web ui presents everything;
  10. I try to replicate the same steps (3-6) for CB 6.0.4 and the webpage UI is not working, but the service and cb commands are responsive.
  11. As an alternative I also tried in top of previous installation of CB 5.x to use rpm -U installer.rpm --relocate /opt/couchbase=/opt/SP/mz/couchbase and the result was also the same;

Can you advise what can be the issue for the upgrade from CB 5.x to 6.0.4?

Hi,

In case someone ends up with this scenario, try upgrading the web browser, it solved the issue.

1 Like