Couchbase 6.5 cbrestore - error in pump_mc.py: struct.error: int too large to convert

Hi,
We are facing issue in restoring cbbackup from Couchbase 4.5.1 to 6.5.1. Process terminates with following error.

[root@localhost bkp]# /opt/couchbase/bin/cbrestore -u Administrator -p ******* /root/bkp/ http://127.0.0.1:8091 --bucket-source=person-data --bucket-destination=person-data
Exception in thread s0:] 17.7% (114000/estimated 642907 msgs)
Traceback (most recent call last):
File “/opt/couchbase/lib/python/runtime/lib/python3.7/threading.py”, line 917, in _bootstrap_inner
self.run()
File “/opt/couchbase/lib/python/runtime/lib/python3.7/threading.py”, line 865, in run
self._target(*self._args, **self._kwargs)
File “/opt/couchbase/lib/python/pump_mc.py”, line 112, in run
rv, batch, need_backoff = self.scatter_gather(mconns, batch)
File “/opt/couchbase/lib/python/pump_cb.py”, line 88, in scatter_gather
vbucket_id=vbucket_id)
File “/opt/couchbase/lib/python/pump_mc.py”, line 233, in send_msgs
conf_res) # type: ignore
File “/opt/couchbase/lib/python/pump_mc.py”, line 595, in cmd_request
ext = struct.pack(">IIQQI", flg, exp, int.from_bytes(meta, byteorder=‘big’), cas, force)
struct.error: int too large to convert

It may not be the same as https://issues.couchbase.com/browse/MB-38683. See the discussion on the following thread.
Cbrestore - Couchbase 4.5 dump to Couchbase 6.5 shows error after 17% of restoring

@jefinjeeva https://issues.couchbase.com/browse/MB-39788 tracks this issue

1 Like

Jeeva,
CB 6.5 is having lot enhancements when compared to 4.5.1.
i recommmend doing a rolling upgrade of 4.5 .1 to atleast 5.5 0r till 6.5 and then take a dump and restore it to 6.5.

Thanks
Rohith

@rvuppala, @pvarley
I have tried XDCR to copy documents from 4.5.1 to 6.5. It successfully copied all documents. Then, I tried to take a dump from 6.5. It showed the same kind of error in CBBACKUP.
Hope this finding help to fix the issue.