Couchbase-cli node-init


#1

Hi,

I’m having a problem running couchbase-cli node-init.
When I run it with a valid –cluster option (ip address), it returns immediately with

ERROR: Could not listen: eaddrnotavail

When I run it with invalid ip address, it waits approx 15 sec and returns

Unable to connect to host at http://10.10.22.223:8091
When I run couchbase-cli server-list with the same valid –cluster option, it returns

ns_1@ip-10-10-22-222.ec2.internal ip-10-10-22-222.ec2.internal:8091 healthy active

I don’t understand why it is returning this eaddrnotavail. I have plenty of ephemeral ports. I’m using 5.5.0. The entire dialog is below:

ec2-user@ip-10-10-23-234 /]$ couchbase-cli node-init --cluster=10.10.22.222 \
--node-init-hostname=ip-10-10-23-234.ec2.internal \
--node-init-data-path=/mnt/datadisk/data \
--node-init-index-path=/mnt/datadisk/index\
 --user=Administrator --pass=password

ERROR: Could not listen: eaddrnotavail
[ec2-user@ip-10-10-23-234 /]$ couchbase-cli node-init --cluster=10.10.22.223 \
--node-init-hostname=ip-10-10-23-234.ec2.internal \
--node-init-data-path=/mnt/datadisk/data \
--node-init-index-path=/mnt/datadisk/index --user=Administrator --pass=password

ERROR: Unable to connect to host at http://10.10.22.223:8091
[ec2-user@ip-10-10-23-234 /]$ couchbase-cli server-list --cluster=10.10.22.222 \
-u Administrator -p password
ns_1@ip-10-10-22-222.ec2.internal ip-10-10-22-222.ec2.internal:8091 healthy active
[ec2-user@ip-10-10-23-234 /]$

#2

Hi,

Can you please let me know what version of CB server you are using?

Also, try specifying you cluster ip in one of the following formats:

  • couchbase://<addr>
  • <addr>:<port>
  • http://<addr>:<port>

Is 10.10.22.222 private IP of your AWS instance or the public one? You should be using the public IP address that is accessible from anywhere and also make sure that your security rules allows traffic to all CB ports mentioned here https://developer.couchbase.com/documentation/server/3.x/admin/Install/install-networkPorts.html


#3

Hi,

Thanks for your reply. 10.0.0.0/8 addresses are always private. We are not planning to ever have public access to the cluster - all access will be within the vpc, no public IP addresses. We are using 5.5.0. I have tried formats that you are referring to - no difference. It is something very fundamental - it does not even try to put a packet on the wire, just errors out immediately. All cb ports are routed.

David