Couchbase count query is so slow

query

#21

Thank you very very much. But the problem is, if I dont use dp.language it takes 30 seconds again. Is this normal response time for 415.000 data ?


#22

CE version only uses limited CPU’s and memory. You can try EE version and see how much you get


#23

You helped me a lot. Thank you very very much


#24

We will use community edition, so I want to fix this problem. Still getting around too much response time. What is the problem ? Is indexing working?

Edit: I tried EE version. Same issue


#25

How many nodes you have? If only 1 then try to use different path for index and data. Second do a get of http://IPAddress:8093/admin/settings with your administrator username and password.

You will get a json, Change the value of pipeline-batch and pipeline-cap to
“pipeline-batch”:2048,
“pipeline-cap”:500000,

if it works then ok else increase “scan-cap”, “servicers” Value. Change max-parallelism to 0.

Do let me know whats the result. And like it if this works.


#26

I am using 1 node. How actually I am going to give different path? Can u explain more ?

Second I did what u said but did not work. Both increase. But I can’t change max-parallelism to 0. It is 5. I can change it to minimum 1.


#27

With EE version, it reduced around 500 - 1000 ms. So community edition is not fast yet in my opinion. In the future, do you think that new features come to community edition so can we use ?