Couchbase Elasticsearch Plugin ( Elasticsearch 2.3.3 support)

#1

Hi All,

I am trying to Install Couchbase ES plugin. ES version is 2.3.3. However, I get the following error message:

ERROR: Plugin [transport-couchbase] is incompatible with Elasticsearch [2.3.3]. Was designed for version [2.3.2]

What are the plans to support ES 2.3.3?

Gurpreet


#2

We usually update the ES fairly regularly but it often lags behind the absolute latest ES releases by some weeks. They release frequently and with the way security for plugins was changed in the 2.x line, each ES release needs its own ES Transport plugin version, which slows us down quite a bit.

So, short answer, there will be an update but I can’t tell you exactly when we will get to it. If you use 2.3.2, you should be good to go.
BTW, there IS a version of the plugin that works with the ES 5.0 Alpha. So we are keeping our eyes out for the new majors and hopefully we can support that pretty quickly once it becomes available.

Best,
-Will

#3

Thanks Will!

Gurpreet