Couchbase Server 4.0 issue


#1

I upgraded my Couchbase server cluster (3 nodes) from 3.0 to 4.0.
But this broke some of the scripts that were working fine in 3.0.
The scripts primarily use the REST APIs that I copied from web console’s View.

In one case:
http://host:8092/cs_work_monitor/_design/dev_classify/_view/unclassified?stale=false&inclusive_end=true&connection_timeout=60000&limit=10&skip=0
works fine. But when I select “Full Cluster Data Set”, i.e. adding “full_set=true”, it broke with this error:
ejson_compare_nif_not_loaded ([{erlang,nif_error,[ejson_compare_nif_not_loaded],[]}, {couch_ejson_compare,less_json_nif,2, [{file,"/Users/jenkins/jenkins/workspace/sherlock-unix/couchdb/src/couchdb/couch_ejson_compare.erl"}, {line,62}]}, {couch_ejson_compare,less_json,2, [{file,"/Users/jenkins/jenkins/workspace/sherlock-unix/couchdb/src/couchdb/couch_ejson_compare.erl"}, {line,49}]}, {couch_set_view,map_view_key_compare,2, [{file,"/Users/jenkins/jenkins/workspace/sherlock-unix/couchdb/src/couch_set_view/src/couch_set_view.erl"}, {line,1116}]}, {couch_skew,merge,3, [{file,"/Users/jenkins/jenkins/workspace/sherlock-unix/couchdb/src/couch_index_merger/src/couch_skew.erl"}, {line,45}]}, {couch_skew,out,2, [{file,"/Users/jenkins/jenkins/workspace/sherlock-unix/couchdb/src/couch_index_merger/src/couch_skew.erl"}, {line,35}]}, {couch_view_merger_queue,handle_cast,2, [{file,"/Users/jenkins/jenkins/workspace/sherlock-unix/couchdb/src/couch_index_merger/src/couch_view_merger_queue.erl"}, {line,155}]}, {gen_server,handle_msg,5,[{file,“gen_server.erl”},{line,604}]}])
I am not sure how to read what’s wrong.

Another case is the “group_level=2” no longer works and return error “unexpected” in dev view and “ejson_compare_nif_not_loaded” in “full cluster data” view.

Is there compatibility issue with upgrading 3.0 to 4.0 data I missed? The upgrade process seems to work fine.

Thanks!

Alex Lee


#2

Are you on OS X El Capitan? It sounds like you might be hitting the problem described here: Couchbase Server issues on OS X El Capitan


#3

Yes, indeed. The cluster is 3 nodes runningMac OSX El Capitan.
I installed the GA version of Mac OSX El Capitan.
Are they still not supported? The installation went ok.
I am not seeing anything mentioned similar to the issue I run into.

Thanks!

Alex


#4

Hi Drigby,

Are you referring MB-16435? Where can I download a newer version that has the fix? Would really appreciate getting this issue unblocked.

Thanks!

Alex


#5

There’s an “El Capitan” specific developer preview build on the 4.0 download page: http://www.couchbase.com/nosql-databases/downloads


#6

I believe that was what I downloaded and upgraded my Couchbase servers from. Will give it a try one more time anyway.

Alex


#7

Hmm… that did the trick. Thanks a lot!
The only difference I notice is the old installation was El Capitan community edition.
This time I installed El Capitan enterprise edition.