Couchbase Server High CPU usage


#1

Hi All,

We have a peculiar issue where couch base server will work perfectly for months but once it start having High CPU then no matter what we do (Uninstall , Purge , Upgrade , Downgrade) The CPU usage will remain High. Until and unless the VM is deleted and created again. Then on new VM the couch base server will work fine.

If we do not destroy the VM and Purge couch base along with removal of /opt/couchbase , then also High CPU state will happen after 5-6 hour and remain same.

We have gone from 4.2 to 5.1 and back to 4.6.2 but this problem remains same.
The couchbase server is used by sync gateway. There is not XDCR. The main process which is taking CPU is beam.smp. The RAM usage is always as low as 20 %.

The cluster is of 2 nodes with one node having >90% CPU usage (the problematic one). with 6 buckets and memory optimised index. less then 20% memory is used. There are 4 core for each node. Data, Query and Index service running on both nodes.All queries, indexing, sync gateway, Rebalance all becomes slow.

The problem is if this happens on production what will be the option even with Enterprise support.
I can share the dev instance (the problematic one) with anybody who can help, I can provide whatever is required to find out the root cause/ solution and work around for this problem.

This problem doesn’t happen on all servers but as soon as this happens nothing works apart from deleting the VM and recreating it and installing couch base again.

Please help as this is becoming a Pain.

CC:- @househippo

Regards
Pankaj Sharma


#2

@pankaj.sharma Did you ever determine what happened here? Running 5.1 in a 3 node cluster and 1 node has been stuck on 100% for a month while the others idle around 10%-20% and during tasks spike to maybe 50%.

Everything seems to work for us still but we’re concerned.


#3

Ya so the issue with sizing. Each bucket connected with sync gateway need 2 CPUs even when the data size is less then 1 GB. So we reduced the number of bucket by merging them. After that this issue haven’t come again.