Couchbase Server very laggy


#1

Hey guys, i have attach a picture of my couchbase sever which always hangs everytime i load it. It will be load finish in about 20 to 30 seconds after hanging. I suspect is because my documents contain an arraylist of base64 string images. Could i gather some feedback


#2

@harrisrezal,
did you set an expiration for documents with 4.0/4.1 ? Then take a look at this: https://issues.couchbase.com/browse/MB-19758


#3

I had a similar issue under load. In my case, the performance of get/insert was just fine, but the admin ui was so laggy. I could not find a solution.


#4

@moon0326,
Most likely the problem is an implementation of iteration over documents for 4.0/4.1 if there are expired documents.
It’s fixed in 4.5 (just 1 line of code), but was not backported to 4.X.
Take a look at your logs, if you see something like that:

2016-05-26T15:35:53.361267Z WARNING (bucket.name) Warning: failed to fetch data from database, vBucket=5 key=|here was key value| error=document not found [none]
2016-05-26T15:35:53.361432Z WARNING (bucket.name) Warning: failed to fetch data from database, vBucket=217 key=|here was key value| error=document not found [none]

then that is https://issues.couchbase.com/browse/MB-19758

@harrisrezal, check this too, please


#5

We don’t really have any expired documents as we don’t set expiration date. It seems like back porting is not a thing in couchbase.


#6

@moon0326,

backporting depends on many things (team of sub-project, processes etc). Take a look at three cases:

So, there is no “strict backporting procedures for all”, many things depend on particular people (developers, team leads etc.)

BTW, keep in mind last one ( https://issues.couchbase.com/browse/MB-19714 ) if you’re using N1QL with 4.X