Couchbase server wont start Mac os

server

#1

Hello,

Im having a issue starting the service on mac osx 10.13.2

When I open the application i can not get to the admin page, server unavailable.

Here is the info logs and the reports logs

[error_logger:error,2018-01-11T13:11:59.788-05:00,ns_1@127.0.0.1:error_logger<0.6.0>:ale_error_logger_handler:do_log:203]
=========================SUPERVISOR REPORT=========================
Supervisor: {local,ns_server_nodes_sup}
Context: start_error
Reason: {abnormal,139}
Offender: [{pid,undefined},
{name,wait_for_couchdb_node},
{mfargs,{erlang,apply,
[#Fun<ns_server_nodes_sup.0.8580514>,[]]}},
{restart_type,permanent},
{shutdown,1000},
{child_type,worker}]

[error_logger:error,2018-01-11T13:11:59.788-05:00,ns_1@127.0.0.1:error_logger<0.6.0>:ale_error_logger_handler:do_log:203]
=========================SUPERVISOR REPORT=========================
Supervisor: {local,ns_server_nodes_sup}
Context: shutdown_error
Reason: {abnormal,139}
Offender: [{pid,<0.162.0>},
{name,start_couchdb_node},
{mfargs,{ns_server_nodes_sup,start_couchdb_node,[]}},
{restart_type,{permanent,5}},
{shutdown,86400000},
{child_type,worker}]

[error_logger:error,2018-01-11T13:11:59.788-05:00,ns_1@127.0.0.1:error_logger<0.6.0>:ale_error_logger_handler:do_log:203]
=========================SUPERVISOR REPORT=========================
Supervisor: {local,ns_server_cluster_sup}
Context: start_error
Reason: {shutdown,
{failed_to_start_child,wait_for_couchdb_node,
{abnormal,139}}}
Offender: [{pid,undefined},
{name,ns_server_nodes_sup},
{mfargs,
{restartable,start_link,
[{ns_server_nodes_sup,start_link,[]},infinity]}},
{restart_type,permanent},
{shutdown,infinity},
{child_type,supervisor}]

[error_logger:error,2018-01-11T13:11:59.789-05:00,ns_1@127.0.0.1:error_logger<0.6.0>:ale_error_logger_handler:do_log:203]
=========================CRASH REPORT=========================
crasher:
initial call: application_master:init/4
pid: <0.87.0>
registered_name: []
exception exit: {{shutdown,
{failed_to_start_child,ns_server_nodes_sup,
{shutdown,
{failed_to_start_child,
wait_for_couchdb_node,
{abnormal,139}}}}},
{ns_server,start,[normal,[]]}}
in function application_master:init/4 (application_master.erl, line 133)
ancestors: [<0.86.0>]
messages: [{‘EXIT’,<0.88.0>,normal}]
links: [<0.86.0>,<0.7.0>]
dictionary: []
trap_exit: true
status: running
heap_size: 376
stack_size: 27
reductions: 107
neighbours:

[error_logger:info,2018-01-11T13:11:59.789-05:00,ns_1@127.0.0.1:error_logger<0.6.0>:ale_error_logger_handler:do_log:203]
=========================INFO REPORT=========================
application: ns_server
exited: {{shutdown,
{failed_to_start_child,ns_server_nodes_sup,
{shutdown,
{failed_to_start_child,
wait_for_couchdb_node,
{abnormal,139}}}}},
{ns_server,start,[normal,[]]}}
type: permanent

[error_logger:info,2018-01-11T13:11:59.789-05:00,ns_1@127.0.0.1:error_logger<0.6.0>:ale_error_logger_handler:do_log:203]
=========================INFO REPORT=========================

[ns_server:error,2018-01-11T13:12:47.808-05:00,ns_1@127.0.0.1:wait_link_to_couchdb_node<0.163.0>:ns_server_nodes_sup:do_wait_link_to_couchdb_node:163]ns_couchdb_port(<0.162.0>) died with reason {abnormal,139}


#2

hi ryant,

did you found how to solve it, I face the same issue on Mac OS X. I have to restart my mac to get couchbase server working