Couchbase Unisntallation Installation error


#1

Hi Folks,

Recently i downloaded Couchbase server 5.0 and installed on my system for R&D purpose.After unistallation when try to re-install getting below errors though my system is fully updated.
Suggestion please?


#2

Hi @ritu.kumari,

What operating system are you using? Can you tell me what files are remaining after uninstallation, and post any logs that you happen to have?


#3

Hi Mathew,

Thankyou for responding.
I am using windows 10 enterprise edition(64-bit).No where in logs this is getting recorded.Any suggestion?


#4

@ritu.kumari,

Do you have administrator privileges on the machine?

The problem you’re having seems similar to this ticket: https://issues.couchbase.com/browse/MB-24575


#5

Hi Mathew,

Happy New Year!
Sorry for late reply.
My server have Universal CRT installed. I verfied looking at location as mentioned in above URL(C:\Windows\System32\ucrtbase.dll or C:\Windows\SysWOW64\ucrtbase.dll)…
Any other alternative.

Thanks
Ritu


#6

Hi @ritu.kumari,

Are you trying to upgrade from 4.5 to 5.0?


#7

@matthew.groves

No i am doing fresh installation.


#8

@ritu.kumari,

Could you try installing again using msiexec /i "C:\MyPackage\Example.msi" /L*V "C:\log\example.log" and then sharing that log file?


#9

@mathew.

PFA log file.error.zip (1.9 MB)


#10

Hi Ritu,

We are looking into this issue. We will update you soon on our finding.


#11

Hi Ritu,
I tried to install and uninstall Couchbase Server 5.0.0 several times on my Windows 10 Pro 64-bit and I could not reproduce your issue. I will get a Windows 10 Enterprise and try to reproduce your issue.
BTW, what is your version and build number of your Windows 10 Enterprise?
Thanks


#12

Hi Ritu,
Base on the log you give us, I found out that the previous uninstall Couchbase Server did not completely remove Couchbase service. Could you try to uninstall completely Couchbase Server and kill any Couchbase services on your Windows. Also, try to kill any erl.exe processes in “Task Manager” windows before install again Couchbase Server 5.0.1.
Here is what I found in your installation logs “WixQuietExec64: C:\Program Files\Couchbase\Server\bin…\erts-5.10.4.0.0.1\bin\erlsrv.exe: A service with the name CouchbaseServer already exists.”

{noformat}
WixQuietExec64:
WixQuietExec64: C:\Program Files\Couchbase\Server>“C:\Program Files\Couchbase\Server\bin…\erts-5.10.4.0.0.1\bin\erlsrv.exe” add CouchbaseServer -stopaction “ns_babysitter_bootstrap:stop().” -name babysitter_of_ns_1@127.0.0.1 -InternalServiceName CouchbaseServer -onfail restart -workdir “C:\Program Files\Couchbase\Server\bin…\bin” -args “-hidden +A 16 +P 327680 -env ERL_FULLSWEEP_AFTER 512 -env ERL_MAX_PORTS 10000 -pa …/lib/couchdb/plugins/gc-couchbase-1.0.0/ebin …/lib/couchdb/plugins/vtree-0.1.0/ebin …/lib/couchdb/plugins/wkb-1.2.0/ebin -sasl -setcookie nocookie -ns_babysitter cookiefile \”…/var/lib/couchbase/couchbase-server.cookie\" -ns_server config_path \"…/etc/couchbase/static_config\" -couch_ini …/etc/couchdb/default.ini …/etc/couchdb/local.ini …/etc/couchdb/default.d/geocouch.ini …/etc/couchdb/default.d/capi.ini …/etc/runtime.ini -kernel inet_dist_listen_min 21100 inet_dist_listen_max 21299 -run ns_babysitter_bootstrap override_resolver – " || goto :error
WixQuietExec64: C:\Program Files\Couchbase\Server\bin…\erts-5.10.4.0.0.1\bin\erlsrv.exe: A service with the name CouchbaseServer already exists.
WixQuietExec64:
WixQuietExec64: C:\Program Files\Couchbase\Server>echo Failed with error 1.
WixQuietExec64: Failed with error 1.
WixQuietExec64:
WixQuietExec64: C:\Program Files\Couchbase\Server>exit /b 1
WixQuietExec64: Error 0x80070001: Command line returned an error.
WixQuietExec64: Error 0x80070001: QuietExec64 Failed
WixQuietExec64: Error 0x80070001: Failed in ExecCommon method
CustomAction RegisterService returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)
Action ended 11:12:13: InstallExecute. Return value 3.
MSI (s) (A4:CC) [11:12:13:236]: Note: 1: 2265 2: 3: -2147287035
MSI (s) (A4:CC) [11:12:13:236]: User policy value ‘DisableRollback’ is 0
MSI (s) (A4:CC) [11:12:13:236]: Machine policy value ‘DisableRollback’ is 0
MSI (s) (A4:CC) [11:12:13:260]: Executing op: Header(Signature=1397708873,Version=500,Timestamp=1277843813,LangId=1033,Platform=589824,ScriptType=2,ScriptMajorVersion=21,ScriptMinorVersion=4,ScriptAttributes=1)
MSI (s) (A4:CC) [11:12:13:260]: Executing op: DialogInfo(Type=0,Argument=1033)
MSI (s) (A4:CC) [11:12:13:264]: Executing op: DialogInfo(Type=1,Argument=Couchbase Server)
MSI (s) (A4:CC) [11:12:13:264]: Executing op: RollbackInfo(,RollbackAction=Rollback,RollbackDescription=Rolling back action:,RollbackTemplate=[1],CleanupAction=RollbackCleanup,CleanupDescription=Removing backup files,CleanupTemplate=File: [1])
Action 11:12:13: Rollback. Rolling back action:
Rollback: RegisterService
MSI (s) (A4:CC) [11:12:13:264]: Executing op: ActionStart(Name=RegisterService,)
MSI (s) (A4:CC) [11:12:13:264]: Executing op: ProductInfo(ProductKey={3E600521-C4A6-40B6-A6C7-21F0B0482074},ProductName=Couchbase Server,PackageName=couchbase-server-enterprise_5.0.1-windows_amd64.msi,Language=1033,Version=83886081,Assignment=1,ObsoleteArg=0,ProductIcon=CouchbaseIcon,PackageCode={DE0BA7F3-4E13-427C-AD58-D3310063BD3F},InstanceType=0,LUASetting=0,RemoteURTInstalls=0,ProductDeploymentFlags=2)
Rollback: FixConfig
MSI (s) (A4:CC) [11:12:13:264]: Executing op: ActionStart(Name=FixConfig,)
Rollback: Copying new files
{noformat}


#13

Thanks Thuan.
I uninstalled completely and tried installing ,it worked.