Couchbasecloud sync_gateway weird behaviour


#1

Hi !

Scenario 1 (same config.json leads to different results):

I created a couchbasecloud sync_gateway named “restaurant” with the following config.json and the GUEST property checked:
{
“interface”:":4984",
“adminInterface”:":4985",
“log”:[“REST”],
“databases”:{
“restaurant”:{
“server”:“http://172.16.1.115:8091”,
“bucket”:“restaurant”,
“importDocs”:true,
“users”: {
“GUEST”:{“disabled”:false, “admin_channels”:["*"]}
}
“sync”:function(doc) {channel(doc.channels);}
}
}

When I type on a browser: http://sync.couchbasecloud.com/restaurant/ I get prompted to a login page asking for login credentials (which is wrong since I’m telling it to allow Anonymous access).

Next, I create a new sync_gateway named “test_” with the same config.json and GUEST checked.
When I type on a browser: http://sync.couchbasecloud.com/test_/ I get this JSON response instead:

{“committed_update_seq”:2,“compact_running”:false,“db_name”:“test_”,“disk_format_version”:0,“doc_count”:0,“instance_start_time”:1393544812047648,“purge_seq”:0,“update_seq”:2}

Why I got different responses if I’m using exactly the same config.json in both cases?

Scenario 2 (After deleting both sync_gateways I still get responses):

I deleted both sync_gateways from my couchbasecloud dashboard.
When I type http://sync.couchbasecloud.com/restaurant/ and/or http://sync.couchbasecloud.com/test_/ I still get the same responses. I did this on different browsers (IE and Chrome) and I got the same results.
Any ideas?
Is there a “time window” on the couchbasecloud server that maintain sessions for some time after sync_gateways are created even after when you explicitly delete them or change settings?

Thanks in advance!

Regards!
//Javier


#2

Would you mind asking questions on the mailing list? This forum is really awkwardly designed and it’s hard to follow things.

You can subscribe to the mailing list here: https://groups.google.com/forum/?fromgroups#!forum/mobile-couchbase

Thanks.