Couchnode build fails Ubuntu 15.04 & CentOS 6.5


#1

I have attempted to build the couchnode package on both Ubuntu 15.04 and CentOS 6.5.

npm install couchbase
npm install “git+https://github.com/couchbase/couchnode.git#master”

I’ve even cloned git and built directly from source.

Each and every time I get the following build errors…any help would be most appreciated.

In file included from …/deps/lcb/src/iofactory.c:22:0:
…/deps/lcb/include/libcouchbase/plugins/io/bsdio-inl.c: In function ‘cntl_impl’:
…/deps/lcb/include/libcouchbase/plugins/io/bsdio-inl.c:312:15: warning: variable ‘so_len’ set but not used [-Wunused-but-set-variable]
socklen_t so_len;
^
In file included from …/deps/lcb/plugins/io/select/plugin-select.c:22:0:
…/deps/lcb/include/libcouchbase/plugins/io/bsdio-inl.c: In function ‘cntl_impl’:
…/deps/lcb/include/libcouchbase/plugins/io/bsdio-inl.c:312:15: warning: variable ‘so_len’ set but not used [-Wunused-but-set-variable]
socklen_t so_len;
^
In file included from …/node_modules/nan/nan_new.h:190:0,
from …/node_modules/nan/nan.h:80,
from …/src/couchbase_impl.h:40,
from …/src/couchbase_impl.cc:21:
…/node_modules/nan/nan_implementation_12_inl.h: In static member function ‘static NanIntern::FactoryBasev8::Signature::return_t NanIntern::Factoryv8::Signature::New(
NanIntern::Factoryv8::Signature::FTH, int, NanIntern::Factoryv8::Signature::FTH*)’:
…/node_modules/nan/nan_implementation_12_inl.h:181:76: error: no matching function for call to ‘v8::Signature::New(v8::Isolate*, NanIntern::Factoryv8::Signature::FTH&,
int&, NanIntern::Factoryv8::Signature::FTH*&)’
return v8::Signature::New(v8::Isolate::GetCurrent(), receiver, argc, argv);
^
…/node_modules/nan/nan_implementation_12_inl.h:181:76: note: candidate is:
In file included from /home/jgreer/.node-gyp/2.2.1/src/node.h:42:0,
from …/src/couchbase_impl.h:39,
from …/src/couchbase_impl.cc:21:
/home/jgreer/.node-gyp/2.2.1/deps/v8/include/v8.h:4188:27: note: static v8::Localv8::Signature v8::Signature::New(v8::Isolate*, v8::Handlev8::FunctionTemplate)
static Local New(
^
/home/jgreer/.node-gyp/2.2.1/deps/v8/include/v8.h:4188:27: note: candidate expects 2 arguments, 4 provided
make: *** [Release/obj.target/couchbase_impl/src/couchbase_impl.o] Error 1
gyp ERR! build error
gyp ERR! stack Error: make failed with exit code: 2
gyp ERR! stack at ChildProcess.onExit (/usr/local/lib/node_modules/npm/node_modules/node-gyp/lib/build.js:269:23)
gyp ERR! stack at emitTwo (events.js:87:13)
gyp ERR! stack at ChildProcess.emit (events.js:172:7)
gyp ERR! stack at Process.ChildProcess._handle.onexit (internal/child_process.js:199:12)
gyp ERR! System Linux 3.19.0-20-generic
gyp ERR! command “/usr/local/bin/iojs” “/usr/local/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js” "rebuild"
gyp ERR! cwd /home/jgreer/src/couchnode
gyp ERR! node -v v2.2.1
gyp ERR! node-gyp -v v1.0.3
gyp ERR! not ok


#2

Hi there, 15.04 is not currently supported in Couchbase, if you wish to use it please use the LTS 14.04 as that is supported. You can find more downloads on http://www.couchbase.com/nosql-databases/downloads. You can also find more information on http://docs.couchbase.com/developer/c-2.4/download-install.html

Laura


#3

Hey greergan,

It would also appear that you are building the Node.js SDK with a version of io.js which is not yet supported by our compatibility layer (nan). Our Node.js SDK releases are tied to specific nan versions, which are tied to specific io.js and node versions due to constant changes in v8 with io.js.

Cheers, Brett