Create Indexes, but It is always restarting


#1

I try to create a index, but never end. It is always restarting.

I have created other indices.

Right now I using version 4.0.0-2213 DEV Edition (build-2213).

Regards


#2

Can you shed more light on this index, cluster setup and data?


#3

Provide the log would also be useful.


#4

Hey guys,

bucket.Query<dynamic>(QueryRequest.Create(@"CREATE INDEX MasterQrsCustomGroupIwpKey ON MasterQrs(iwps) USING GSI"));

The log:

Port server indexer on node 'babysitter_of_ns_1@127.0.0.1' exited with status 1. Restarting. Messages: github.com/couchbase/indexing/secondary/indexer.func·037(0xc084eea180)
C:/Jenkins/workspace/sherlock-windows/couchbase/goproj/src/github.com/couchbase/indexing/secondary/indexer/mutation_manager.go:837 +0x251
created by github.com/couchbase/indexing/secondary/indexer.(*mutationMgr).persistMutationQueue
C:/Jenkins/workspace/sherlock-windows/couchbase/goproj/src/github.com/couchbase/indexing/secondary/indexer/mutation_manager.go:857 +0x3c0
[goport] 2015/07/15 15:22:19 c:/Program Files/Couchbase/Server/bin/indexer.exe terminated: exit status 2

I have another question, When I created the cluster set Data, Index, Query in the same cluster, Its ok?

Regards


#5

Regarding your second question, yes it is fine to create a node with all 3 services activated.

Your log seem to indicate that the indexing service crashes, but it is unclear as to why. Did you capture logs on the server side as well? (refer to Couchbase documentation on the cbcollect tool, I think it should also collect data on indexer and query service).


#6

@simonbasle

I Attached the log: https://mega.nz/#!A4YTGADK!L0DKSaejMYu4vZHptL7QLf1kCZtGQmI_SA_Btd9Eo84


#7

Hi @simonbasle,

Did you saw the logs?

Regards


#8

I’m not from the core team so my experience is very limited to debug such an issue. I’ve filed a JIRA ticket on your behalf however, you can track it here: https://issues.couchbase.com/browse/MB-15751


#9

@simonbasle ,Thanks a lot.


#10

@Antx2207 apparently it looks like you’re running out of memory (see the comment on the jira issue).

Maybe you need to better tune memory quotas for buckets and indexer? You should also monitor available free memory from the OS.


#11

@simonbasle, Perfect! We are testing now at AWS. I am very grateful for your help.

Regards


#12

Glad I could help, hope the tests go well :smile: