Disable couchbase server from running on startup


#1

Hello everyone.
I have started running couchbase server on my laptop for development and from what I can see, couchbase server is set by default to be loaded on startup. I Don’t mind but my booting time is now appalling, despite the good system resources. Is there a way to stop couchbase server from running on startup(centos 6.5)? Thanks!


#2

This of course depends on your OS but here are the common ways:

MacOS X
There is a setting if you click on the Couchbase Server icon in the Menu bar

Windows
You can edit the start configuration via the Services, the easiest way to get there is I guess
WinKey + X -> Task Manager -> Services -> Right Click -> Open Services. Now search for Couchbase Server, Right Click to get to Properties and edit the startup type

Linux
Edit the the update-rc.d, so something like $ update-rc.d couchbase defaults should do the trick

Hope that helps.