Don't see bucket (password protected) in CBworkbench


#1

I use couchbase server vesion - 4.0.0-4047 Enterprise Edition.
And I’m using Query Workbench Developer Preview 1.0.1.

When I open workbench , i don’t see my bucket(password protected) displayed in ‘Meta-deta’ section. I do have primay index created and ‘index’,‘query’,‘data’ services are enabled in couchbase server.

By the way it used to display and I was able to run N1QL queries couple of weeks back. I don’t understand what changed in last couple of weeks.


#2

Hello, sorry for the delay getting back to you, my forums account got messed up.

Can you bring up the web browser’s error console, and see if there are any errors there?

Also, what results do you see when you run the following query (which is what I use to get a list of buckets and their index status):

select max(keyspace_id) id, max(has_primary) has_prim, max(has_second) has_sec, max(secondary_indexes) sec_ind from (
select indexes.keyspace_id, true has_primary
from system:indexes where is_primary = true
union
select indexes.keyspace_id, true has_second, array_agg(indexes.index_key) secondary_indexes, indexes.condition
from system:indexes where is_primary is missing or is_primary = false group by keyspace_id having keyspace_id is not null
union
select id keyspace_id from system:keyspaces except
(select indexes.keyspace_id from system:indexes union select “” keyspace_id)
) foo group by keyspace_id having keyspace_id is not null order by keyspace_id

Thank you,

-Eben


#3

I don’t see any errors in browers error console.

And I ran your query and here’s the output of it.

[
{
“has_prim”: null,
“has_sec”: null,
“id”: “beer-sample”,
“sec_ind”: null
},
{
“has_prim”: null,
“has_sec”: null,
“id”: “default”,
“sec_ind”: null
},
{
“has_prim”: true,
“has_sec”: null,
“id”: “gamesim-sample”,
“sec_ind”: null
},
{
“has_prim”: true,
“has_sec”: true,
“id”: “travel-sample”,
“sec_ind”: [
[
"airportname"
],
[
"city"
],
[
"faa"
],
[
"icao"
],
[
"name"
],
[
"sourceairport"
],
[
"type"
]
]
}
]


FYI , If i remove password for my bucket then I’m able to query against my bucket but not when it’s password protected


#4

Hi again.

Did the name of your password protected bucket show up in results of the query above? I.e., was your password-protected bucket “default” or one of the sample buckets? The query I sent you is what I use to generate the list of buckets for the UI. If your password-protected bucket doesn’t show up in the results, I need to find out why.

Thank you!

-Eben


#5

Hello,

My bucket is not in the results up there. My bucket name was ‘Pricing’. By the way I upgraded my local couchbase to 4.1 version but there’s no change with it. I still cannot see password protected bucket.

Not sure if following info helps in your troubleshooting.
If I connect to another remote couchbase server (in this case it’s our projects QA server - stand-alone/single node again) I’m able to see the password protected buckets from that QA server. To connect my workbench to QA , i launch launch-cbq-gui.bat with COUCHBASE_URL & other fields set appropriately.

I’m starting to wonder if there’s any setting changes required within couchbase server ?

Let me know if you want me to check on any other thing.