Dpkg: error processing archive couchbase-release-1.0-4-amd64.deb (--install):


#1

Hello,
i’m trying to install Couchbase server on a virtual machine (virtual box) running
Ubuntu Server 18.04 (GNU/Linux 4.15.0-23-generic x86_64).
Following this guide, if i run

sudo dpkg -i couchbase-release-1.0-4-amd64.deb

console shows me:

(Reading database ... 103765 files and directories currently installed.)
Preparing to unpack couchbase-release-1.0-4-amd64.deb ...
Supported platforms are: Debian/wheezy,jessie and Ubuntu/lucid,precise,trusty,xenial

dpkg: error processing archive couchbase-release-1.0-4-amd64.deb (--install):
 new couchbase-release package pre-installation script subprocess returned error exit status 1
Errors were encountered while processing:
 couchbase-release-1.0-4-amd64.deb

What am i missing?
I’ve already tried the docker solution and it worked, and now i would like to install permanently because i’d like to test it in “production mode”.

NB: i checked out this topic, and it seemed having the same problem. I checked systemd, and it’s on pid 1, so it should’t be that.

Thank you in advance


#3

The problem is that the couchbase-release package checks the distribution on install to ensure it matches the supported platforms, and Bionic (Ubuntu 18.04) isn’t a supported platform yet.


#4

No, distribution is not a problem there is also the same issue on Ubuntu Xenial and Trusty


#5

Hmm. Can you check to see if the ‘lsb-release’ package is installed on your system? The couchbase-release package depends on the lsb_release command which is provided by that package.


#6

lsb-release is installed and Im getting the same error all the time, checked Mint 18 and Ubuntu 16.04 Xenial


#7

Mint 18 is not a supported distro either. It should definitely work on Ubuntu 16.04 however. I’ve verified it working in an Ubuntu 16 Docker container so long as lsb-release is installed.

Can you tell me the output of “lsb_release -a” on your Ubuntu 16 system?


#8

Thanks for replay, I managed to install it. The solution was to change distrocode for Xenial Xenial in lsb_release. It works now both on Mint 19 and Ubuntu 18.04


#9

Glad you’re unstuck!