Elasticsearch plugin

#1

Hello,

I want to know if Elasticsearch Plugin 2.1.1 is compatible with Elasticsearch 2.x.

If not, when does the new plugin will be available?

Thanks

#2

Hi Jose

The product compatibility can be found here:

To answer your question more directly, no, the Elasticsearch Transport Plugin 2.1.1 is not compatible with Elasticsearch 2.x.

However, there is work going on to create a compatible version. You can track that here: https://github.com/couchbaselabs/elasticsearch-transport-couchbase/issues/101

Just be aware that we don’t announce projected release dates.

If you’re in a hurry, there’s another option. At least one user reported successfully building the plugin from source themselves using “bignolip”'s fork of the project (linked in issue 101 above).

Best,
-Will