Enable LDAP authentication

Hi all,

I would like to know how to enable ldap authentication for my couchbase cluster ? In the admin interface => security => external user/role, I already clicked and had “authentication enabled”. But I do not have “LDAP Auth Setup” tab on settings tab.

I do not know how to have depsite of searching around.

Thanks for your helps.

Best regards,


Hello @uthng,

You’ll need to install and configure the saslauthd agent on all your Couchbase Server nodes.

See LDAP Authentication and Setting up saslauthd.