Erl crash dump on Windows 7 64 bit after 3.03 / 3.01 reinstall


#1

Had 3.01 Community installed and set the service to manual start. Updated back to automatic start and attempted to start the service and the admin port refused the connection. Uninstalled and installed 3.03 with no luck. Uninstalled and reinstalled 3.01 Community, and still no luck. The error is consistent. Here’s the first few lines of the erl_crash.dump file.

Any help would be appreciated.

=erl_crash_dump:0.3
Wed May 13 13:11:21 2015
Slogan: Kernel pid terminated (application_controller) ({application_start_failure,ns_server,{{shutdown,{failed_to_start_child,cb_couch_sup,{shutdown,{failed_to_start_child,couch_app,{‘EXIT’,{{badmatch,{err
System version: Erlang R16B03 (erts-5.10.4) [64-bit] [smp:8:8] [async-threads:16]
Compiled: Mon Dec 9 20:22:33 2013
Taints: crypto,mapreduce


#2

hi @cgarrity

it could be that one of the components is still listening to a couchbase port (or that another program as already registered one of couchbase ports. Did you try to uninstall, restart the machine and reinstall?

Can you check that no other application uses couchbase ports (less likely since it was working in manual starting mode…) http://docs.couchbase.com/admin/admin/Install/install-networkPorts.html

If that’s not it, then we’ll need more detailed logs.
edit use the cbcollect_info tool on the node to collect relevant logs into a zip file:

  • tool is in under C:\Program Files\Couchbase\Server\bin\cbcollect_info under Windows
  • use command cbcollect_info collect.zip