Error about using couchbase-cli command to do cluster-init

#1

Hi there, I am now tring to use couchbase-cli command to do cluster-init after installing the couchbase rpm package. The command is as below, but had no luck and got a following error. Fyi my couchbase version is 4.5.0, anyone happened this and know the issue reason?

couchbase-cli cluster-init -c 127.0.0.1:8091 --cluster-username=Administrator --cluster-password=password --cluster-port=8091 --services=data,index,query --cluster-ramsize=1024 --cluster-index-ramsize=512 --index-storage-setting=memopt

{“errors”:{“storageMode”:“storageMode must be one of forestdb, memory_optimized”}}

also tried set index-storage-setting as “default”, but still no lucky:

couchbase-cli cluster-init -c 127.0.0.1:8091 --cluster-username=Administrator --cluster-password=password --cluster-port=8091 --services=data,index,query --cluster-ramsize=1024 --cluster-index-ramsize=512 --index-storage-setting=default

{“errors”:{“storageMode”:“storageMode must be one of forestdb, memory_optimized”}}