Error trying to install PHP client on Debian 9


#1

When I enter this command:

sudo dpkg -i couchbase-release-1.0-4-amd64.deb

I get the following error:

dpkg: error processing archive couchbase-release-1.0-4-amd64.deb (–install):
subprocess new pre-installation script returned error exit status 1
Errors were encountered while processing:
couchbase-release-1.0-4-amd64.deb

Not sure what to do, as the error message is totally unhelpful…
Thanks in advance.


#2

You can follow the guide on archives page and add this source to your APT

deb http://packages.couchbase.com/ubuntu stretch stretch/main


#3

It worked. Thank you!
(guide is here: https://developer.couchbase.com/server/other-products/release-notes-archives/c-sdk)