Eventual support for io.js/nodejs v4.0.0 (NAN >= 2.X)


#1

Hi,
I just stumbled upon this article, https://medium.com/node-js-javascript/4-0-is-the-new-1-0-386597a3436d.

I was wondering if moving to NAN >= 2.X was on you road map to eventually support the merge of iojs and nodejs to v 4.0.0 with a major upgrade to V8 ?

Thank you
JF


Node SDK fails on Mac 10.11 (El Capitan)
#2

I too would like to upgrade to Node v4, but the couchbase node sdk is what is holding me back. Is there any news on a update to that sdk to support the new version of Node?


#3

Hey Guys,

Node.js 4.0.0 is supported as of the 2.1.1 release of our SDK. Check it out!

https://www.npmjs.com/package/couchbase

Cheers, Brett


#4

Awesome !

Thank you Brett


#5

I am having trouble specifically running N1QL queries from the new 2.1.1 release of the SDK. All other queries seems to work fine, but when I run a N1QL query i get this error:

“Process finished with exit code 139”

I was wondering if anyone else experienced this problem and knew of a solution.

I am running Node v4 and Couchbase Server 4.0 RC0. As well as using version 2.1.1 of the sdk. I am running all of this on OSX Yosemite 10.10.2.

Thank you
Andrew